I need help quick please!!! - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-20-2011, 02:19 PM Thread Starter
Compression Ignition Addict
svranger25's Avatar
Join Date: Mar 2010
Posts: 294
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I need help quick please!!!

i drove down for 3 hours to the beach pulling a very light load maybe 1500 to 2000 pounds and when i arrived and got out of my truck i heard a ticking sound i had no power loss no overheating nothing wrong on stock gauges, or my boost, tranny temp, and exhaust temp gauges, they were all normal,,, it sounds like something is scrapping but when i spin the fan it doesn't hit but i read somewhere else if the fan spins easily it could be a bad fan clutch,,, please help because i need to get it fixed before i drive back,,, it is a 1996 f350 crew cab long bed 4x4 7.3L with aftermarket turbo and intercooler.
svranger25 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome