Please Help! - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 01-07-2011, 05:49 AM Thread Starter
Compression Ignition Addict
 
ONE BAD EXCURSION's Avatar
 
Join Date: Jan 2008
Location: HARTSVILLE, SC
Posts: 212
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Please Help!

Got in my 02 X this morning drove to work no problems. 2 hours later got in it cranked fine and went to get something to eat. When I went back to the truck 30mins later the truck turned over and then it was like the battery died. Would not turn over starter and would click but would not turn over. Please help!!

2002 EXCURSION 7.3 WITH BANKS 4" EXHAUST, SWAMPS STAGE 1 SPLIT SHOT INJECTORS S175/146, S&B COLD AIR INTAKE, FPR MOD WITH FUEL GAUGE, TUNES BY MATT @ GEARHEAD AUTOMOTIVE , AUTOMETER GAUGES PYRO, TRANS TEMP, BOOST, 6.0L INTERCOOLER, TN BB TURBO, DINO CROSS CONNECT KIT, DINO HIGH PRESSURE CROSSOVER, ADRENALINE HPOP FROM DIESELSITE


ONE BAD EXCURSION is offline  
post #2 of 4 Old 01-07-2011, 06:18 AM
Premium Member
 
bondsman's Avatar
 
Join Date: Apr 2008
Location: Moyock, NC
Posts: 1,273
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Wrong section but anyways.... Check the batteries, connections and terminals. Could be a bad starter. Over time the starter will slow down its cranking speed as it wears out. Did it crank pretty fast when it would start? If not, suspect the starter. Check all of your grounds as well..

05 F250 4x4 CC, 9.5" Rize/Icon, 38" Toyos, 20x12 Pacers, 5" MBRP, AFE stage 2, Cass 190s, Powermax, ELC w/filter, RCD EGR delete
04 Excursion 4x4, vacation bus
Project 1979 F250 6.0 powered in progress


bondsman is offline  
post #3 of 4 Old 01-07-2011, 06:35 AM Thread Starter
Compression Ignition Addict
 
ONE BAD EXCURSION's Avatar
 
Join Date: Jan 2008
Location: HARTSVILLE, SC
Posts: 212
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I have 2 new optima battery and new alternator. Lights come on radio plays. It would start slow like it had a bad battery and then it would take off.

2002 EXCURSION 7.3 WITH BANKS 4" EXHAUST, SWAMPS STAGE 1 SPLIT SHOT INJECTORS S175/146, S&B COLD AIR INTAKE, FPR MOD WITH FUEL GAUGE, TUNES BY MATT @ GEARHEAD AUTOMOTIVE , AUTOMETER GAUGES PYRO, TRANS TEMP, BOOST, 6.0L INTERCOOLER, TN BB TURBO, DINO CROSS CONNECT KIT, DINO HIGH PRESSURE CROSSOVER, ADRENALINE HPOP FROM DIESELSITE


ONE BAD EXCURSION is offline  
post #4 of 4 Old 01-07-2011, 12:14 PM
Compression Ignition Addict
 
jdffafarmer's Avatar
 
Join Date: Aug 2009
Location: Defiance, OH
Posts: 470
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I would say starter...sounds exactly like what my 97 was doin last summer

2012 F250 Extended Cab Long Box 4x4


jdffafarmer is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome