Yet Another NON running problem - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-02-2010, 04:12 PM
Powerstroke.org Rookie
 

Join Date: Dec 2010
Location: Kansas City
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question Yet Another NON running problem

I have a 94 F250 4X4 Manual 7.3l Truck has 210k. I am a mechanic in the Army for 16 years now. I have exp, but am not sure after checking what I know to check.

Initial problem was would stop running while driving. No electric fuel pump so tapped on manual pump and truck would start up and run fine, for a little while.

Replaced fuel pump(not my first time). Would not start.

started blowing #22 fuse. Through reading the forum, replaced GPR, still blew fuse.

Disconnected wire at fuel filter fuel heater. Stopped blowing fuse.

Wait to start light comes on and goes off after a few seconds.

Truck cranks fine but no smoke and no hint of starting.

When replacing pump, broke i think it is called the ICP, boght new one and replaced. still not starting up.

Checked Fuel filter for fuel and fuel reaches the top of filter.


What should I check next ???
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-02-2010, 04:17 PM
Rangers Lead The Way!
 

Join Date: Nov 2009
Posts: 11,484
Thanks: 0
Thanked 11 Times in 9 Posts
Feedback Score: 2 reviews
check your wiring going to the injectors, also check the IDM (injector driver module) and the the IPR (injector pressure regulator). Could also be PCM
Reply With Quote Quick reply to this message
  #3  
Old 12-02-2010, 04:51 PM
Powerstroke.org Rookie
 

Join Date: Apr 2010
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
your rpm gauge move while cranking the engine over? If not then its your cps.
Reply With Quote Quick reply to this message
  #4  
Old 12-02-2010, 06:58 PM
Powerstroke.org Rookie
 

Join Date: Dec 2010
Location: Kansas City
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Not Sure

Have not looked at the tach, the oil pressure moves while cranking !!
Reply With Quote Quick reply to this message
  #5  
Old 12-02-2010, 07:00 PM
Rangers Lead The Way!
 

Join Date: Nov 2009
Posts: 11,484
Thanks: 0
Thanked 11 Times in 9 Posts
Feedback Score: 2 reviews
haha well oil pressure is a good thing
Reply With Quote Quick reply to this message
  #6  
Old 12-02-2010, 07:19 PM
Powerstroke.org Rookie
 

Join Date: Dec 2010
Location: Kansas City
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
YES

Yes oil pressure is a good thing !!! I have been swamped at work all week, will be able to takle this problem Sat and Sun !!

Thank you for all of the feed back !!!
Reply With Quote Quick reply to this message
  #7  
Old 12-02-2010, 07:33 PM
Compression Ignition Addict
 

Join Date: Dec 2006
Location: Lincoln NE
Posts: 203
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Is this an IDI 7.3 or a "Powerstroke" 7.3?
Reply With Quote Quick reply to this message
  #8  
Old 12-02-2010, 07:35 PM
Rangers Lead The Way!
 

Join Date: Nov 2009
Posts: 11,484
Thanks: 0
Thanked 11 Times in 9 Posts
Feedback Score: 2 reviews
its a psd, idi didnt have 22 fuse or a fuel bowl in that respect
Reply With Quote Quick reply to this message
  #9  
Old 12-02-2010, 07:35 PM
Powerstroke.org Rookie
 

Join Date: Dec 2010
Location: Kansas City
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
PowerStroke

It is a PowerStroke !
Reply With Quote Quick reply to this message
  #10  
Old 12-02-2010, 07:44 PM
Compression Ignition Addict
 

Join Date: Dec 2006
Location: Lincoln NE
Posts: 203
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Make sure you have good ground cables and connections from your batteries.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:57 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors