Turbo fins gone? - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 11-29-2010, 09:07 PM Thread Starter
Powerstroke.org Rookie
 
Powerstroker1488's Avatar
 
Join Date: Sep 2010
Location: Antioch IL
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Unhappy Turbo fins gone?

Hi,
I have a 96 powerstroke 235k 10k mod trq lock mod no cat or muffler. I found a hole at the end of the exhaust port on the head about 1 inch long and 1/4 inch wide. Its not on the exhaust manifold. I have never seen such a thing before. Well i put muffler mend on there and it lasted for 4 months. The turbo had a decent whistle. Since it started getting cold out and the ebpv valve has been activating it cracked the mend and left me with a hole and a few pieces in my up pipe. I got out the bronze brazing rod and brazed it right up. The only problem is i got quite a bit of slag in the manifold and was rattling around the up pipes with the mend before going through the turbo. Could this cause damage to the turbo fins on the exhaust side to the point where there is no whistle anymore? The turbo used to be at full spool around 2500 rpm and now its hard to tell may even be phsyco schematic but it doesnt pull hard anymore at 2500rpm im not sure if its boosting properly or if i destroyed my turbo. Maybe i knocked off a boot or finally popped a weak spot on the cold side with the added boost. I have not done a boost check but i will tmro. The motor sounds like a Bluebird school bus with the 7.3 t444E in it. Wondering if this is ultimatly how it is supposed to sound or what. Any help would be great.
Powerstroker1488 is offline  
post #2 of 3 Old 12-01-2010, 10:02 AM
Banned
 
Join Date: Oct 2009
Location: Riverside/Norco, Ca
Posts: 3,771
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 2 reviews
hate to say it but you might want to pull your turbo, check everything, and PLEASE vacuum out anything and everything if you may have put debris in it...
Dietoremain is offline  
post #3 of 3 Old 12-01-2010, 06:00 PM Thread Starter
Powerstroke.org Rookie
 
Powerstroker1488's Avatar
 
Join Date: Sep 2010
Location: Antioch IL
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
thats what i was afraid of Oh well i guess when i get a job
Powerstroker1488 is offline  
Reply

Tags
brazing , ebpv , manifold , turbo , welding

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome