runing really rough - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-14-2010, 02:59 AM
Member
 

Join Date: Dec 2008
Location: anchorage alaska
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
runing really rough

yesturday i was on my way to work and pulled out on the street and went to get on it like always and the truck just wouldnt go it was sputtering and had absotlutley no power i dont think i was able to get it above 35 at top so i turned around to bring it home and it died on me it started up after i turned the key bout 3 times and was bearly running but enough to get it home i ran a diagnostics with the programmer i have and came up with the code: P0603- pcm processor keep alive memory (KAM) error. not sure what all that means and i was thinking that i either got a bad injector or the o rings on the injectors are bad its been blowin white smoke even when warm and when it was sputtering it was blowing blueish smoke plus the truck has een running really rough lately the rpms would drop to 500 or just under but then go back to normal but still be running really rough any help would be much appreciated thanks

sorry for the long post.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-14-2010, 04:11 AM
COME ON...ONE TIME!!


 

Join Date: Sep 2007
Location: Fletcher, NC
Posts: 16,735
Thanks: 64
Thanked 57 Times in 55 Posts
Feedback Score: 0 reviews
checked your fuel filter lately? Pump maybe?
Reply With Quote Quick reply to this message
  #3  
Old 10-14-2010, 12:54 PM
Member
 

Join Date: Dec 2008
Location: anchorage alaska
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i havent checked the fuel filter lately but i replaced it not to long ago same time i replaced the fuel pump but i maght have gotten a bad fuel pump cause it didnt seem to have the power it did before
Reply With Quote Quick reply to this message
  #4  
Old 10-14-2010, 02:58 PM
Member
 

Join Date: Dec 2008
Location: anchorage alaska
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i checked the fuel filter and oil and i was really low on oil so the sputterig i think was the engine kickin into the run safe mode and the fuel filter is durty and the fuel in the bowl is a dark grey. is that a sign of my injector o rings going bad or leaking?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:52 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors