97 psd runs,then dies under acceleration...HELP - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-09-2010, 03:46 PM
Powerstroke.org Rookie
 

Join Date: Aug 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
97 psd runs,then dies under acceleration...HELP

Hi im new to the forums here. this is my first powerstroke..its a 1997 with 260,000 miles on it. Any help would be greatly appreciated.

I got the truck in non-running condition.got it for a real good price,had a brand new tranny and the body was in great shape. About a week of tinkering on it and doing tests i found the engine computer was bad.So i found a known good ecm. i plugged that in and she cranked and cranked and fired up. ran great idling with a little white smoke i figured from sitting for about 5 months it would smoke a little. after i let it warm up i took it down the block it ran great and then when i went to get on it alittle it died out... i let it sit and it fired back up. so after that i stuck a new lift pump on it. i pulled all 8 injectors out finding that they were brand new stage ones. all of the valve cover harness look great. i also replaced the cps sensor along with borrowing my friends idm.. after all that i changed the oil and it sill does the same thing. the truck will run and run all day long idling or even driving until you put your foot in it. after the truck dies it will crank and crank and crank then fire up but then shut right back down.

please help me out ,im running out of ideas any help i would really appreciate
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-21-2010, 11:01 AM
Compression Ignition Addict
 

Join Date: Jun 2010
Location: fort oglethorpe
Posts: 170
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
could be running out of hp oil...just a guess
Reply With Quote Quick reply to this message
  #3  
Old 10-21-2010, 11:18 AM
Compression Ignition Addict
 

Join Date: May 2010
Location: Raleigh, NC
Posts: 3,499
Thanks: 7
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
hpop or fuel filter most likely
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:07 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors