PCM Wanted - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-22-2014, 07:42 PM
Powerstroke.org Rookie
 

Join Date: Oct 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
PCM Wanted

I have an 11/96 build date FSuperduty that needs a good PCM anyone have one laying around or know of the best place to purchase a good PCM please let me know. have cash/paypal/wire in hand if your in texas ill come get it thanks!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-22-2014, 08:52 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 1,825
Thanks: 0
Thanked 43 Times in 43 Posts
Feedback Score: 0 reviews
Probably need to provide a bit more info. What numbers are on your current PCM? Is your truck Auto or Manual, and do you know if it is a California truck or not? Cheers!
Reply With Quote Quick reply to this message
  #3  
Old 06-23-2014, 05:29 PM
Powerstroke.org Rookie
 

Join Date: Oct 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
well thinking it may no be the PCM I am experiencing a loss of power with no cel but i am getting the p0603 code, which I am finding may be more to do with the programmer than the problem. I am also getting p0470 and p0478.

the truck

11/96 build date 1997 F Superduty (F450)

PSD

zf 5speed

3.5" down pipe and using a superchips micro tuner at the moment although I am likely to move to a 6 position from TS

otherwise the truck is completely stock

also fixing to go to 373 dana gears and need to resolve the power loss as I am sure it will become increasingly evident once I am regeared
Reply With Quote Quick reply to this message
  #4  
Old 06-23-2014, 06:58 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 1,825
Thanks: 0
Thanked 43 Times in 43 Posts
Feedback Score: 0 reviews
The 603 code is from the tuner. 470 and 478 are exhaust backpressure codes. Check the EBP senor and connection and also check the EBPV butterfly to make sure it is not hanging up slightly shut, etc. Cheers!
Reply With Quote Quick reply to this message
  #5  
Old 07-14-2014, 09:27 PM
Powerstroke.org Rookie
 

Join Date: Oct 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
got it fixed. turned out to be the back presure sensor $175 from ford for a new one and all is good
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:46 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors