E4OD Issues Codes Ran - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 05-06-2012, 12:02 PM Thread Starter
Member
 
Join Date: Oct 2011
Location: Blairsville, PA
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
E4OD Issues Codes Ran

Hello and goodafternoon,

So I was dricing back from the grocery store the other day and noticed my truck was shifting rough and the OD light was flashing on the shift selector. I plugged a few scanners up to it and no codes.

Brought it to a buddy and he plugged his 3,000 dollar snap on scanner and ran a code for P1728 torque converter clutch failing to engage.

After calling some places they told me to drop the pan and test the solenoids. So I did so, tested them all and the all the resistance was in spec.

Anyone know where I should go next? Ive been told to replace the TC but I do not want to drop the transmission and spend the money on the TC when there potentially could be something else I can check.

I have a 97 PSD 7.3 CCLB E4OD

Any help would be much appreciated. Thanks in advance.

Dexter16 is offline  
post #2 of 3 Old 05-06-2012, 01:42 PM Thread Starter
Member
 
Join Date: Oct 2011
Location: Blairsville, PA
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I also visually checked the overdrive shift selector wiring down from the shifter all the way to the main harness and everything checked out okay.
Dexter16 is offline  
post #3 of 3 Old 05-07-2012, 09:05 PM
Compression Ignition Addict
 
Join Date: Dec 2011
Location: Northern Arizona
Posts: 2,251
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Thanks: 0
Thanked 16 Times in 16 Posts
Feedback Score: 4 reviews
Check the main connector on the right side of the transmission. Make sure that it is clean and dry.

Jack
97 F250 Xlt, built E4od, D60 swap, Baby swamps, tunes by Dp
1.0 turbo housing, 203* t-stat, diy 6637, 4" exhaust
Diy intercooled, 6.0 fan, Diy 140v Idm, Isspro Ev gauges
On board air,E-fuel, 5" lift on 35's
320000 miles
1Dieselman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome