rough shifts, no speedo - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 12-20-2011, 10:35 AM Thread Starter Fanatic
07PSD's Avatar
Join Date: Mar 2011
Location: alden, NY
Posts: 121
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
rough shifts, no speedo

im working on a 95 at work. it slams into 2nd (havent taken it over 30 on the test drive so prob all gears) and has no speedo/odo. abs light is not on and od light is not flashing. i already replaced to VSS with a Napa one. the napa one looked a little diff but over all the same and the plug fit. i checked for power at the VSS plug and im getting 5 volts. i read on here that the speedo sends power to the VSS so im assuming the speedo isnt broke. is there another sensor in the trans that could casue this?


1996 f-250 4x4 auto, eclb. 2.25" PMF RSK, v codes, D60, 4" tb, 6637, Tru Cool 40k, 08 front bumper, 18x9.5 AR Mojave w/ 33x12.5 Atturo MT
1998.5 2500 ecsb 2wd NV4500, 100's, HE351, Adrenaline pv2, DTT Assassin, Banks intake horn, BHAF, Autometer Cobalts, 4" tb to 7" miter, slipping stock clutch.
07PSD is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome