Clutch Trouble - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 10-15-2010, 05:31 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jun 2010
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Clutch Trouble

okay i bought a solid mass flywheel/clutch kit from val air, i installed it and i had to do major adjustment, even pedal travel under the dash. the pedal is VERY stiff, everything works new slave cylinder i am just stumped i also notice a slight noise coming from the tranny till i press the pedal anything is appreciated thanks
97jokerstroker is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 03-04-2012, 12:00 PM
Compression Ignition Addict
 
Jameson Bearden's Avatar
 
Join Date: Aug 2008
Location: Chatsworth, Ga
Posts: 272
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Having the same problem with my truck just the noise though

1995 F250 ECLB ZF5 4X4:
3" DP to 4" Exhaust
Tymar Intake
CCV Mod
Valair Clutch
Gauges
Jameson Bearden is offline  
post #3 of 5 Old 05-29-2012, 11:22 PM
Compression Ignition Addict
 
usramc's Avatar
 
Join Date: May 2012
Location: Williamsburg, Ky
Posts: 287
Thanks: 2
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
Same noise here, I've heard that its most often not a bad throw out bearing but just the bearing rubbing the clutch fork. anyone who wants to chime in it will be greatly appreciated, my clutch and pressure plate still look good but I just hate to drop that tranny to put grease on that bearing.

Early 99, 6 speed, ccsb, leveling kit on 35's, 6634, straight pipe, diablo chip.
usramc is offline  
post #4 of 5 Old 05-30-2012, 10:52 AM
Compression Ignition Addict
 
Join Date: Aug 2008
Location: Madison, WI
Posts: 3,957
Thanks: 4
Thanked 135 Times in 131 Posts
Mentioned: 0 Post(s)
Quoted: 38 Post(s)
Feedback Score: 0 reviews
Hmm, usu. the replacement clutches (except maybe the really high HP ones) provide a much lighter pedal feel. Sounds like either something wasn't assembled right (pilot or throwout bearing facing the wrong way?), or a problem with the fork. Did you install a new fork? IIRC, there's a known problem with the OEM, and Ford has a replacement.
madpogue is offline  
post #5 of 5 Old 05-30-2012, 11:06 AM
Compression Ignition Addict
 
nccatfan's Avatar
 
Join Date: Sep 2007
Location: Burlington, NC
Posts: 1,007
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to nccatfan
Had a Valair clutch installed in my Super Duty a couple years ago. Pedal started out very stiff for me too. Eventually it softened up (got the one rated for up to 600hp). Didn't notice any odd noises tho.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

-'99 F250 7.3L PSD 4x4 (SCLB, 6-speed)
-'14 F150 4x4 5.0 CCSB
-'83 Ranger 4X4 5.0

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
nccatfan is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome