7.3 power stroke problem I'm lost! - Ford Powerstroke Diesel Forum
911 Urgent Situations Emergency Forum , Need Help Fast ? Post Here ! Urgent Topics Only

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-03-2014, 07:58 PM
Powerstroke.org Rookie
 

Join Date: Apr 2014
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exclamation 7.3 power stroke problem I'm lost!

Hey guys I just got an 02 7.3 powerstroke a few. Ugh ya ago he told me it needed a idm but after I went and looked and finally got the truck to crank it ran great and he really didn't no what he was talkin about much like myself. I have replaced the ipc and cps but truck still wants to suddenly die while driving and another trick it started a little whole ago is it will now idle but won't hardly let me rev it just sputters. What's rong woth my truck?! Help plz
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-03-2014, 08:39 PM
Premium Member

 

Join Date: Jul 2013
Location: AUBURN, ALABAMA
Posts: 294
Thanks: 0
Thanked 11 Times in 11 Posts
Feedback Score: 0 reviews
WELCOME TO THE ORG !!! Clean oil? Right oil at proper level? Clean fuel and filter? Water in fuel? Proper fuel pressure / good strong pump? Loose or chaffed valve cover / injector wiring harness? Loose or chaffed Injector Driver Module harness (IDM inside driver fender well)? Good luck...
Reply With Quote Quick reply to this message
The Following User Says Thank You to AU7POINT3 For This Useful Post:
Buff (04-05-2014)
  #3  
Old 04-04-2014, 04:28 PM
Powerstroke.org Rookie
 

Join Date: Apr 2014
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Could be the wiring under valve cover I guess i don't no why I put the new sensor in and it caused this tho
Reply With Quote Quick reply to this message
  #4  
Old 04-04-2014, 04:46 PM
Premium Member

 

Join Date: Jul 2013
Location: AUBURN, ALABAMA
Posts: 294
Thanks: 0
Thanked 11 Times in 11 Posts
Feedback Score: 0 reviews
may not be the new sensor causing it, but something else wiggled loose along the way.
Reply With Quote Quick reply to this message
The Following User Says Thank You to AU7POINT3 For This Useful Post:
Buff (04-05-2014)
  #5  
Old 04-04-2014, 04:47 PM
Premium Member

 

Join Date: Jul 2013
Location: AUBURN, ALABAMA
Posts: 294
Thanks: 0
Thanked 11 Times in 11 Posts
Feedback Score: 0 reviews
Not likely the new sensor, but something else wiggled loose or chaffed along the way.
Reply With Quote Quick reply to this message
  #6  
Old 04-05-2014, 07:35 AM
Powerstroke.org Rookie
 

Join Date: Apr 2014
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I agree after continuously messing with it I got it running a and drove 15 miles no issues but left it in the driveway idling suddenly once again it's like ilyou cut the key truck started right back up tho. I do notice when it is running it doesn't sound quite right tho. I left it sitting for awhile and came back started it and same thing sputters and sputters until I cut it off and start it 20 times and the engine gets warm then it seems to rub decent still doesn't sound correct tho. I'm leaning twards injector harnesses what do you all think?? Thanks for the help!
Reply With Quote Quick reply to this message
  #7  
Old 04-06-2014, 01:40 PM
Compression Ignition Addict
 

Join Date: Feb 2013
Location: Washington, PA
Posts: 595
Thanks: 15
Thanked 20 Times in 20 Posts
Feedback Score: 0 reviews
is there a performance chip in your truck. if so unplug it from the pcm. ?
Reply With Quote Quick reply to this message
  #8  
Old 04-06-2014, 06:17 PM
Powerstroke.org Rookie
 

Join Date: Apr 2014
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I've already done that man it has a TS THATS it. I don't no what to do in thinkin possible and idm now I wish I new someone that had one I could barrow to rule that out
Reply With Quote Quick reply to this message
  #9  
Old 04-06-2014, 06:51 PM
Compression Ignition Addict
 

Join Date: Apr 2013
Location: Salvisa, Kentucky
Posts: 382
Thanks: 7
Thanked 9 Times in 9 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by Buff View Post
I've already done that man it has a TS THATS it. I don't no what to do in thinkin possible and idm now I wish I new someone that had one I could barrow to rule that out
Do you know any one who has a diagnostic scanner?
Reply With Quote Quick reply to this message
  #10  
Old 04-06-2014, 07:03 PM
Premium Member
 

Join Date: Jan 2009
Location: Almost to the Muck but not quite
Posts: 1,526
Thanks: 43
Thanked 75 Times in 72 Posts
Feedback Score: 0 reviews
7.3 power stroke problem I'm lost!

If guy you purchased from said it needed an IDM then maybe it does.

You can get one on ebay for 130$ exchanged from a place down here in FL
Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
ipr icp, missing, rev, stalling while driving, won't start

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:58 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors