brakes not working - Ford Powerstroke Diesel Forum
911 Urgent Situations Emergency Forum , Need Help Fast ? Post Here ! Urgent Topics Only

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 01-15-2014, 03:54 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
brakes not working HELP please

working on my 96 f350 with the engine running you push on the brake pedal it goes to the floor you can pump the pedal up but it will fade with the engine off it will not fade I've put new calipers on the front so i could bleed the system and tried 3 different master cylinders but nothing seems to work help please

UPDATE the entire brake system has been replaced vac pump, vac booster, 5 master cylinders, all the steel lines, all rubber lines, wheel cylinders, shoes, hardware kit, drums and properly adjusted. front calipers, rotors, and pads. also bypassed the abs module. it's properly bleed we pedal, pressure, vacuum, and gravity bleed the system any help would be much appreciated

Last edited by roadkillwi; 01-21-2014 at 03:41 PM. Reason: update
roadkillwi is offline  
post #2 of 4 Old 01-22-2014, 03:31 PM
Premium Member
 
midnite rider's Avatar
 
Join Date: Feb 2013
Location: Washington, PA
Posts: 2,362
Thanks: 118
Thanked 98 Times in 97 Posts
Mentioned: 3 Post(s)
Quoted: 280 Post(s)
Feedback Score: 0 reviews
u listed everything possible that it could be are you sure u do not have a vac leak to the booster

-Tom

05 250 KING RANCH CCSB,278k,ARP's,SCT TSX,Atlas 40,STC done,Glowshift FP Gauge,Banks IC System,Blue Spring,Banjo's,CCV mod,Oil Bypass,Diamond Eye 5" Exhaust,Bilstein 5100's,RC Dual Steering Stabilizer,Retro 55W 6k Heads 3k Fogs,Continental Airbags,RSD 48 gal Aux Fuel Tank.





2003 F350 Lariat CCSB, 288K, Everything But Studs.
midnite rider is offline  
post #3 of 4 Old 01-22-2014, 04:41 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
im getting 25 pounds of vacuum at the booster and the booster holds vac for a long while with engine off
roadkillwi is offline  
post #4 of 4 Old 01-23-2014, 02:09 PM
Premium Member
 
midnite rider's Avatar
 
Join Date: Feb 2013
Location: Washington, PA
Posts: 2,362
Thanks: 118
Thanked 98 Times in 97 Posts
Mentioned: 3 Post(s)
Quoted: 280 Post(s)
Feedback Score: 0 reviews
now i am stumped, i`ll talk to my buddy see if he can figure it out he`s a 7.3 guru

-Tom

05 250 KING RANCH CCSB,278k,ARP's,SCT TSX,Atlas 40,STC done,Glowshift FP Gauge,Banks IC System,Blue Spring,Banjo's,CCV mod,Oil Bypass,Diamond Eye 5" Exhaust,Bilstein 5100's,RC Dual Steering Stabilizer,Retro 55W 6k Heads 3k Fogs,Continental Airbags,RSD 48 gal Aux Fuel Tank.





2003 F350 Lariat CCSB, 288K, Everything But Studs.
midnite rider is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome