03 f350 stopped running while running, stuck on the road - Ford Powerstroke Diesel Forum
911 Urgent Situations Emergency Forum , Need Help Fast ? Post Here ! Urgent Topics Only

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-09-2013, 08:44 PM
Powerstroke.org Rookie
 

Join Date: Nov 2011
Location: cleveland
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exclamation 03 f350 stopped running while running, stuck on the road

Hello first off thanks for the help. I have a 2003 f350, 6.0l, 4x4, CCLB. I was on my way home from work and pulled away from a traffic light got up to 50mph then noticed i would not go any faster with my foot to the floor. I eased off the throttle and the truck slowed to 45 then i got back on it and my truck would not go over 45 it would just hold what ever speed i was at. I then looked at my guages and everything was normal, temp, oil pressure, everything. Well i came to a stop and the truck shut off on its own. Now it cranks and cranks it acts like its fireing or tryin to while cranking but will not stay running. I have fuel, checked all my fluids. No idea what it can be. So im sitting here on the side of the road trying to track down a buddys to give me the tow of shame. I need to get to work tomorrow evening. Please help with some input! Thanks again!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-01-2013, 06:31 AM
Powerstroke.org Rookie
 

Join Date: Nov 2011
Location: cleveland
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hooked a laptop up to it and everything was good except oil psi. it was jumping between 450-500 at full duty cycle. Welp i ended up tearing into it amd getting down to the hpop to check everything out. Hpop looked and checked out ok, ball bearing was still in. Checked for high pressure oil leaks and couldnt locate any. Noticed oil on my icp plug so replaced that and the pigtail. Replaed the ipr valve put it all back together and still dose the same thing. Hooked the laptop up and noticed smaller numbers in oil pressure. So i moved to the low pressure system. Regulator seemed good not real scoreing or debris in it. Got into the lopop amd found my problem. Needle bearing prints stamped all over the gears deep ground grooves in the covers. Looks like a whole lot of fun ahead of me....joy
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:11 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors