00 Excursion Cruise Control Not working, 1200 mile trip in 2 days - Ford Powerstroke Diesel Forum
911 Urgent Situations Emergency Forum , Need Help Fast ? Post Here ! Urgent Topics Only

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-15-2012, 05:44 PM
Powerstroke.org Fanatic
 

Join Date: Apr 2008
Posts: 133
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
00 Excursion Cruise Control Not working, 1200 mile trip in 2 days

2000 Ford Excursion 7.3L Auto

It was working off and on for awhile now but about a month ago quite all together, now i just found out I need to make a long trip in 2 days and ford doesn't have the time to troubleshoot it before the trip..

I did take it to ford but the service manager was not the greatest, he was trying to help me out but didnt solve anything.. He did check the Switches to the PCM but that was about all he could do with the laptop..


Checked

ON- Good to PCM
OFF- Good to PCM
Coast- Good to PCM
Accel/Set- Good to PCM
Resume- Good to PCM
Fuse(s) on Recall Harness Both Good
E-Brake Switch, Light off on dash with brake off, Brake Light on when brake On
Speedometer is steady on the gauges, not bumpy
I have checked ALL Fuses inside and in engine compartment

Replaced
Brake Light Switch under dash with Ford OEM NEW
Brake Pressure Deactivation Switch on end of Brake Master Cly


Only Codes on the PCM

P0541 Air Inlet Heater circuit low ( I have deleted this heater )
P0470 Exhaust Back pressure reading incorrectly (tried to clean it but needs new)


I can think nor find anything else that would be holding it out

I guess if I cant get it working there is all ways a brick, but I want it to work properly.



PLEASE PLEASE PLEASE anybody have anything else or suggestions

Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-12-2013, 07:17 PM
Compression Ignition Addict
 

Join Date: Sep 2011
Location: Indianapolis, IN
Posts: 210
Thanks: 13
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
did u ever get it figured out
Reply With Quote Quick reply to this message
  #3  
Old 04-14-2013, 08:04 PM
Powerstroke.org Rookie
 

Join Date: Mar 2013
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Did you check the switch on the master brake cylinder?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:47 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors