Help! Just died on the side of the road! - Ford Powerstroke Diesel Forum
911 Urgent Situations Emergency Forum , Need Help Fast ? Post Here ! Urgent Topics Only

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 04-22-2012, 09:30 AM Thread Starter
Member
 
Join Date: Jul 2011
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Help! Just died on the side of the road!

Taking an exit off the highway and she stalled and will not restart. Plenty of fuel, oil, battery and Fi voltage.
Likely the fuel pump? Anything I can check sitting here?

2005 SRW f350 Lariat CC 8ft bed, black!
Matches my 03 black turbocharged Marauder!
jupiter is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 04-22-2012, 09:43 AM Thread Starter
Member
 
Join Date: Jul 2011
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well, I got her started and she idles fine, but when I press the accelerator nothing happens. No response at all.

2005 SRW f350 Lariat CC 8ft bed, black!
Matches my 03 black turbocharged Marauder!
jupiter is offline  
post #3 of 8 Old 04-22-2012, 10:07 AM
Compression Ignition Addict
 
jimmyv13's Avatar
 
Join Date: Jul 2007
Location: West Bloomfield, MI
Posts: 1,715
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 3
Thanked 4 Times in 4 Posts
Feedback Score: 3 reviews
Send a message via AIM to jimmyv13 Send a message via Yahoo to jimmyv13
Do you have any way to check PID's?


2005 F250 CCSB Lariat FX4

4" MBRP Turbo Back*High Idle*Blue Spring*Updated Stand Pipes, Dummy Plugs*SGII w/Blendmount*Sinister Coolant Filter*SRL+*'10 Tailgate*2" level*Dicad EGR delete*Premium EdFICM*Powerslot Rotors*Hawk Pads*Riffraff boots*DIY CCV*4" Rear Blocks*ARP's*'10 Tails*Archoil*N-FAB Steps*'12 Rear Bumper*Dashboss*'08 Trans Pan
*Bullitt y-pipe
jimmyv13 is offline  
post #4 of 8 Old 04-22-2012, 10:20 AM Thread Starter
Member
 
Join Date: Jul 2011
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ther are no engine codes. I let her idle for 20 minutes and then tried to start her again, no luck. Rough when trying to start her again and would not start. Pulled the accelerator assembly off, nothing I can do there.

2005 SRW f350 Lariat CC 8ft bed, black!
Matches my 03 black turbocharged Marauder!
jupiter is offline  
post #5 of 8 Old 04-22-2012, 10:28 AM Thread Starter
Member
 
Join Date: Jul 2011
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I don't hear the fuel pump running either. There is a lot of background noise but I should hear it.

2005 SRW f350 Lariat CC 8ft bed, black!
Matches my 03 black turbocharged Marauder!
jupiter is offline  
post #6 of 8 Old 04-22-2012, 11:00 AM
Compression Ignition Addict
 
jimmyv13's Avatar
 
Join Date: Jul 2007
Location: West Bloomfield, MI
Posts: 1,715
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 3
Thanked 4 Times in 4 Posts
Feedback Score: 3 reviews
Send a message via AIM to jimmyv13 Send a message via Yahoo to jimmyv13
TPS - Throttle Position Sensor

Quick search, anything in here help?


2005 F250 CCSB Lariat FX4

4" MBRP Turbo Back*High Idle*Blue Spring*Updated Stand Pipes, Dummy Plugs*SGII w/Blendmount*Sinister Coolant Filter*SRL+*'10 Tailgate*2" level*Dicad EGR delete*Premium EdFICM*Powerslot Rotors*Hawk Pads*Riffraff boots*DIY CCV*4" Rear Blocks*ARP's*'10 Tails*Archoil*N-FAB Steps*'12 Rear Bumper*Dashboss*'08 Trans Pan
*Bullitt y-pipe
jimmyv13 is offline  
post #7 of 8 Old 04-22-2012, 11:04 AM Thread Starter
Member
 
Join Date: Jul 2011
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hmmmm. Checked the fp fuse and it looked fine, but apparently wasn't. Changes the fuse and she started right up.
Hmmm. Hopefully it will get me home but needs further investigation... Any suggestions as to why that would happen?

2005 SRW f350 Lariat CC 8ft bed, black!
Matches my 03 black turbocharged Marauder!
jupiter is offline  
post #8 of 8 Old 08-23-2012, 09:55 AM Thread Starter
Member
 
Join Date: Jul 2011
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just an FYI, it was a dirty EGR valve that causes limp mode and no starts.

2005 SRW f350 Lariat CC 8ft bed, black!
Matches my 03 black turbocharged Marauder!
jupiter is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome