96 F350 7.3 URGENT! Oil suddenly appearing, idles fine, no power when driving! - Ford Powerstroke Diesel Forum
911 Urgent Situations Emergency Forum , Need Help Fast ? Post Here ! Urgent Topics Only

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-31-2011, 04:34 PM
Powerstroke.org Rookie
 

Join Date: Oct 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exclamation 96 F350 7.3 URGENT! Oil suddenly appearing, idles fine, no power when driving!

Hello everyone,

Ok here is my situation which I need to try and fix before work Monday if at all possible. I have a 96 F350 7.3 4x4 with only about 176k miles. It has a brand new fuel pump, filter, alternator, and heater core.

A few days ago is when my problems seem to start. I was driving down the road and stopped at a red light, truck was running fine and had been driving it for about 30 minutes with no issues. Light turned green, hit the gas, and the truck barely moved. I had to go like 1mph through the intersection where I pulled over and turned the truck off. I could not find anything wrong, all fluids were fine, oil and tranny as well.

Got back in the truck, turned it on and had power again and it drove fine rest of trip to work. When I got off work, again it drove fine until about last 15 minutes of trip it suddenly just shut off. Fired right back up and drove rest of way home with no issue.

Well today I decided to take it about 2 miles up the road to the gas station. Again it fired up fine, drove fine to the gas station and back home until the last half mile to my house.

Suddenly the truck jerked as if something was holding it back and there was ONE loud clunk. Truck did not stall, did not run rough, and kept going down the road. But from that point on it would have power for a few seconds to the wheels then lose power and feel like it was being held back. It did this constantly the last half mile home after that clunk. NOTE: IT NEVER MADE ANOTHER CLUNK NOISE AFTER THAT. IT ALSO IDLES AND FIRES UP JUST FINE.

Got home parked the truck, crawled underneath it and now there is oil coating my driver side lower half of motor and the entire underside of motor. Checked the dip stick and it is showing no oil on it. I just checked the oil when it stalled the day or so before and it was full. There was no drips or leaks or puddles under truck when I left for gas station. (I know this because I backed up and checked because I was watching for symptoms of what caused it to act up the day or so before).

My question is, does anyone have any idea what the heck is wrong with this truck? My first guess was transmission going out. But now with the oil I have no clue because the motor is not running rough or anything and yes I did put oil back in it as soon as I noticed it was all on the ground or coating bottom of engine. What was the loud clunk I heard?

Much appreciated for speedy replies. This is my transportation to work so without it I'd be in an even worse situation.

Thanks,
Justin
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:21 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors