No fuel pressure - Ford Powerstroke Diesel Forum
911 Urgent Situations Emergency Forum , Need Help Fast ? Post Here ! Urgent Topics Only

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-03-2011, 09:18 AM
Member
 

Join Date: Jul 2011
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No fuel pressure

97 PSD with CPR fuel system. Changed the pre-pump filter the other day and it took a little while to purge the air from the system and settle back at 65psi. I adjusted it down to 60 the same day and it was fine on the drive to work this morning. Now, both the gauge in the engine bay snd in the cab are rwading zero. The truck is running fine though. At a quick glance everything looks connected and no leaks. ????
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-03-2011, 10:49 AM
Member
 

Join Date: Jul 2011
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
New development: tried to drive home, did fine coming out of work, although I never get above 30. When I pulled onto the highway I tried to accelerate from the red light and I noticed it was very rough with significant reduction in power. I was able to get up to speed and cruise at 55 just fine. I had to stop at a red light, where it idled fine, but even worse this time when I tried to go. Pulled over to check things out again and found nothing. No leaks, no blow by, and still no fuel pressure. Cranks and idles fine. Feels rough when you rev it, even in neutral. I limped it to the diesel shop down the road and they will look at it in the morning.

I'm baffled as to how it is running without fuel pressure. Or at least none on the gauges.
Reply With Quote Quick reply to this message
  #3  
Old 11-04-2011, 11:19 AM
Member
 

Join Date: Jul 2011
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It was the fuel pump.
Reply With Quote Quick reply to this message
  #4  
Old 11-04-2011, 11:23 AM
Compression Ignition Addict
 

Join Date: May 2010
Location: Raleigh, NC
Posts: 3,433
Thanks: 5
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
I'm guessing it had enough prime to pull fuel through but the pump just wasn't pushing enough to make pressure
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:56 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors