2002 7.3 big pop, hiss, oil smell, no boost afterwards! - Ford Powerstroke Diesel Forum
911 Urgent Situations Emergency Forum , Need Help Fast ? Post Here ! Urgent Topics Only

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 06-25-2011, 08:46 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jun 2011
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question 2002 7.3 big pop, hiss, oil smell, no boost afterwards!

Hi there have a 2002 7.3 w/banks exhaust, chip tuned, afe air box. Acellerating on to freeway this AM and heard/felt loud POP up top, hissing sound for a few seconds, slight oil smell came into cab but dissipated in a minute or two, and immediately lost all boost.
No oil leaking that I can see, no loud mechanical grinding truck runs and files fine. Just no boost and slight whine out of turbo when you throttle up. Hoping this might just be a blown boot or something simple. Hope somebody has experience or knows? Thanks to all in advance. Don
pdqbassman1 is offline  
post #2 of 5 Old 06-25-2011, 09:00 AM
Compression Ignition Addict
 
97_stroke's Avatar
 
Join Date: Dec 2006
Location: Lincoln NE
Posts: 203
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Blown intercooler boot for sure.

97' F-250 extended cab 5-spd, 4" AFE exhaust, Tymar cold air intake, guages, Modified IDM, Stage 2 injectors, Complete fuel system, TS 6 pos. chip, Southbend Con OFE clutch, D66 turbo - Gone

08' F-250 CCSB, Spartan 275 tuned, exhaust, S&B CAI - Gone (miss it)

2007 -duramax (who cares)- Gone!

2002 -F-350 CCLB - Gone

2013 - F350 CCSB 6.7 Here!
97_stroke is offline  
post #3 of 5 Old 06-25-2011, 09:14 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jun 2011
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Smile thanks much!

Here is hoping for an easy fix. Thanks again!
pdqbassman1 is offline  
post #4 of 5 Old 06-27-2011, 06:09 AM
Compression Ignition Addict
 
97_stroke's Avatar
 
Join Date: Dec 2006
Location: Lincoln NE
Posts: 203
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hopefully! Did you figure it out?

97' F-250 extended cab 5-spd, 4" AFE exhaust, Tymar cold air intake, guages, Modified IDM, Stage 2 injectors, Complete fuel system, TS 6 pos. chip, Southbend Con OFE clutch, D66 turbo - Gone

08' F-250 CCSB, Spartan 275 tuned, exhaust, S&B CAI - Gone (miss it)

2007 -duramax (who cares)- Gone!

2002 -F-350 CCLB - Gone

2013 - F350 CCSB 6.7 Here!
97_stroke is offline  
post #5 of 5 Old 06-27-2011, 06:19 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jun 2011
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Smile Right on the money!

Thanks again! The front intake boot had blown off. I had to take it off when I was replacing a power steering pump hose and must not have gotten it over the flange and tight enough. Thanks again guys
pdqbassman1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome