Incapacitated & Pegged speedo - Ford Powerstroke Diesel Forum
911 Urgent Situations Emergency Forum , Need Help Fast ? Post Here ! Urgent Topics Only

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 06-10-2011, 04:16 PM Thread Starter
Premium Member
 
GreenF350's Avatar
 
Join Date: Jan 2007
Location: Florida Panhandle
Posts: 1,710
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Exclamation Incapacitated & Pegged speedo

Need some ideas on where to look. NWFLPS calls me and tells me his truck is undriveable. His speedo pegged, odometer is rolling fast even though he is only doing 25mph. Transmission sometimes acts like it is in high gear and sometimes acts like the torque converter is locked. (won't pull away from a stop without stalling). Runs fine in neutral/reverse/park. Pulled plug for VSS and no change. He does have a Tru-Speed installed but tried pulling the fuse on that and also no change. Any ideas where to look? Kind of stumped on this one and don't know enough about the system. Any help appreciated. Thanks guys (or gals)!
-Aaron

2000 Ext. Cab F350 SRW, 6" Skyjacker lift on front/8" BDS Springs on rear w/NO blocks, 37x13.50 Nitto Mud Grappler's, Aftermarket Front Bumper

-Always More Stuff Coming!

Last edited by GreenF350; 06-10-2011 at 04:39 PM.
GreenF350 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-10-2011, 07:21 PM Thread Starter
Premium Member
 
GreenF350's Avatar
 
Join Date: Jan 2007
Location: Florida Panhandle
Posts: 1,710
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Update...still haven't found anything really useful yet, but it had 3 codes on it. P0733 Gear 3 ratio incorrect, P0340 CPS signal incorrect and P0720 OSS incorrect output. Just in case that rings a bell for anyone.

2000 Ext. Cab F350 SRW, 6" Skyjacker lift on front/8" BDS Springs on rear w/NO blocks, 37x13.50 Nitto Mud Grappler's, Aftermarket Front Bumper

-Always More Stuff Coming!
GreenF350 is offline  
post #3 of 3 Old 06-11-2011, 08:29 AM Thread Starter
Premium Member
 
GreenF350's Avatar
 
Join Date: Jan 2007
Location: Florida Panhandle
Posts: 1,710
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Well, disconnect the Tru-speed and it drove the 40 miles back to his house just fine, so we are thinking that was the problem, hard to say though since it was intermittent. Just thought I'd throw in the results in case someone comes across this thread in a search.
-Aaron

2000 Ext. Cab F350 SRW, 6" Skyjacker lift on front/8" BDS Springs on rear w/NO blocks, 37x13.50 Nitto Mud Grappler's, Aftermarket Front Bumper

-Always More Stuff Coming!
GreenF350 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome