need help asap. - Ford Powerstroke Diesel Forum
911 Urgent Situations Emergency Forum , Need Help Fast ? Post Here ! Urgent Topics Only

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 02-16-2011, 05:12 AM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Nov 2010
Location: Medford OR
Posts: 111
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
need help asap.

alright guys i will try to make this fast. yesterday my truck ran just fine no issues that i could notice. well this morning i started my truck with the remote start like i do every morning. i left to work got about a half a mile away and my speedometer started going crazy and my od off light started flashing. so i pulled over at a gas station and when i shut the truck off the heater and the air bag light would not shut off and there was a wierd sound coming from under the dash almost like a relay making a grinding noise. dont really know how to explain the sound. as soon as you turn the key back on all the lights on the dash come on like they always do and that noise quits. so now i am missing work today so i need help if anyone know. thanks for reading sorry it is so long.






4" straight pipe exhaust
afe stage 2 cai
dp-tuner f5 switch
zoodad
d pricol a pillar guages
dppowrstroke is offline  
post #2 of 10 Old 02-16-2011, 05:25 AM
Compression Ignition Addict
 
Join Date: Dec 2007
Posts: 2,900
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 7
Thanked 1 Time in 1 Post
Feedback Score: 2 reviews
subscribed, good luck

2008 6.4 f250 lariat 4wd
melmount is offline  
post #3 of 10 Old 02-16-2011, 07:32 AM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Nov 2010
Location: Medford OR
Posts: 111
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
anyone please






4" straight pipe exhaust
afe stage 2 cai
dp-tuner f5 switch
zoodad
d pricol a pillar guages
dppowrstroke is offline  
post #4 of 10 Old 02-16-2011, 08:04 AM
Compression Ignition Addict
 
Join Date: Dec 2007
Posts: 2,900
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 7
Thanked 1 Time in 1 Post
Feedback Score: 2 reviews
try googling the GEm module. I have heard these going and peoples lights flashing and things not being correct??

2008 6.4 f250 lariat 4wd
melmount is offline  
post #5 of 10 Old 02-16-2011, 08:09 AM
Compression Ignition Addict
 
justinlogue5_0's Avatar
 
Join Date: Mar 2010
Location: Westmoreland,Tn
Posts: 2,008
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Also check the main power cable connection on the side of the under the hood fuse box. Have heard that it can corrode and cause weird issues like this also. Just some thing else to check I guess.

NAME: Justin


A little bit of this and a little bit of that. I want a lot more of this and a lot more of that It never ends!
justinlogue5_0 is offline  
post #6 of 10 Old 02-16-2011, 08:29 AM
Compression Ignition Addict
 
Join Date: Dec 2007
Posts: 6,194
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 73 Post(s)
Thanks: 7
Thanked 232 Times in 223 Posts
Feedback Score: 3 reviews
Yea, look here ->
Need Help ASAP Stranded at Work 03 7.3L Electrical Wont Start

You should Always list your Year & Model when asking for help so, I don't even know if this is gonna be relevant.....
NoRalPh is offline  
post #7 of 10 Old 02-16-2011, 08:57 AM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Nov 2010
Location: Medford OR
Posts: 111
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
hey thanks guys. i looked up the gem module and i found on here some discribing the same problems as me becouse his windshield leaked on it as soon as it dried no more problems. i am gonna go check that power cable right now. sorry about not including the year i will remember that from here on.






4" straight pipe exhaust
afe stage 2 cai
dp-tuner f5 switch
zoodad
d pricol a pillar guages
dppowrstroke is offline  
post #8 of 10 Old 02-16-2011, 09:15 AM
Powerstroke.org Rookie
 
wynn456's Avatar
 
Join Date: Nov 2010
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had the same problem as you did turned out that the windshield was leaking on the gem/fuse panel fixed the leak and replace the the fuse panel due to the leak causing it to have corrosion in the boards . Now all good. Mine the radio would stay on and the turn signals and the key/door buzzer was going off
wynn456 is offline  
post #9 of 10 Old 02-16-2011, 10:15 AM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Nov 2010
Location: Medford OR
Posts: 111
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
so i went and checked for that main power connector. i could not find it so if anyone knows where it could be on a 2000 psd that would be awsome thanks






4" straight pipe exhaust
afe stage 2 cai
dp-tuner f5 switch
zoodad
d pricol a pillar guages
dppowrstroke is offline  
post #10 of 10 Old 02-17-2011, 07:22 PM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Nov 2010
Location: Medford OR
Posts: 111
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
alright guys i couldent find anything wrong my truck. so i took it in to a well known local mechanic today he hooked my truck up to the computer and the gem is good the only codes it is throwing is low voltage and some other electric codes. so he told me that who ever hooked up my remote start did a crappy job and i need to un hook a nd take out all of the remote start stuff and that would fix my issue. has anyone heard of this?






4" straight pipe exhaust
afe stage 2 cai
dp-tuner f5 switch
zoodad
d pricol a pillar guages
dppowrstroke is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome