crank but no start - Ford Powerstroke Diesel Forum
911 Urgent Situations Emergency Forum , Need Help Fast ? Post Here ! Urgent Topics Only

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-11-2011, 12:17 PM Thread Starter Rookie
Join Date: Feb 2011
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
crank but no start

Hey guys, the name is Bruce. I'm new here and was hoping you all could give me some info. I have a 2004 F-350 6.0L. I was driving it today and it seemed fine, drove for about 20 more minutes when it sputtered a few times and just cut off. The truck is now sitting and cranks continuously but will not fire. I got under the truck and the pump is running and seems to be sending fuel. I know my ICP sensor is going bad but all of the ICP sensor problems I have dealt with in the past the truck would still fire, it would just run terrible. I have read a lot about the HPOP but need to know if anyone else had any ideas. I am not sure how to get to the HPOP to work on it. Any info would be great.
regarkecurb is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome