6.0 injector ? - Ford Powerstroke Diesel Forum
911 Urgent Situations Emergency Forum , Need Help Fast ? Post Here ! Urgent Topics Only

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-30-2011, 11:36 AM Thread Starter
Powerstroke.org Rookie
Join Date: Jan 2011
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.0 injector ?

I have a 6.0 F350 2006, The egr was out. So replaced the oil cooler, egr delete kit, and a 5" off road exhaust. When i was pulling out the old exhaust it pushed the injector connection in the 7 th position (which is the back left) one into the housing. So when I went to connect it it keept trying to push back into the housing, I had to hold it with a screw driver to plug it in and the clip doesn't seem like it is holding it very well. I started it and it ran for 15-20 minutes than shut down and want start. Someone else stated i have the air in the high pressure oil is the reason it want start now. But now the 7th injector is causing a code. Do i need to replace the whole injector? Would this be causing it not to start? I have been fighting with this days.
bgrantom is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome