91 IDI Auto tranny troubles??? - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-28-2008, 08:31 PM
Compression Ignition Addict
 

Join Date: Nov 2006
Posts: 194
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
91 IDI Auto tranny troubles???

Just bought a 1991 F-350 cew cab single wheel 4x4 truck, with 138-k miles. 7.3L IDI, automatic overdrive and BONE STOCK other than oversized tires and wheels. (315x75R16's)

Tranny seems slow going into reverse (like 3 to 5 seconds) and sometimes slow going into drive, while driving it seems a little funny to me going into OD sometime as well. Fluid looks good and has no smell to it. Is this something common with the IDI's or do I need to have it checked out???
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-07-2009, 01:30 PM
The Screwy HEUI
 

Join Date: Jan 2008
Location: Smithfield, RI
Posts: 4,585
Thanks: 5
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by texasstroker View Post
Just bought a 1991 F-350 cew cab single wheel 4x4 truck, with 138-k miles. 7.3L IDI, automatic overdrive and BONE STOCK other than oversized tires and wheels. (315x75R16's)

Tranny seems slow going into reverse (like 3 to 5 seconds) and sometimes slow going into drive, while driving it seems a little funny to me going into OD sometime as well. Fluid looks good and has no smell to it. Is this something common with the IDI's or do I need to have it checked out???
The E4ODs do develop some slop between gears over time, but 3-5secs. don't sound right. Think maybe something's having a hard time engaging, like a clutch band?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:37 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors