94 idi turbo diesel hard starting.... - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 12-01-2008, 04:09 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2008
Location: UP of Michigan
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
94 idi turbo diesel hard starting....

Hello, i have a 94 (non powerstroke) idi turbo diesel. About a month ago it got really hard starting in the mornings. After it is initially started it starts just fine, but not if it sits overnight. The "wait to start" light i have noticed only stays on for a second or two compaired to a few seconds. Also there is a loud ticking sound from the timer thing..... so whats my problem, timer, or glow plugs., or what....???? Don't know too much about the idi diesels....any info would help.
pro11 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 12-01-2008, 04:56 PM
Emergency Services

 
Broncoguy's Avatar
 
Join Date: Jul 2008
Location: Benton City, WA
Posts: 338
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Glow plugs

Most likely your glow plug control module. The solenoid does not fail very often, but the flat black piece the solenoid is bolted to goes bad on a regular basis.(The solid state timer part)

Cheapest I have seen them is $125.00 on Ebay. I just had the same problem you are describing for the 3rd time in 2 years. I bypassed the control timer and now I just use a momentary switch to control the solenoid. Push the button, count to 10 and she fires right up every time now.

Could still be the glow plugs themselves, but the controller is more common.

How old are the glow plugs and relay that are in it now?

1999.5 F350
4" Straight Pipe / Gauges (Pyro, Boost)
Wicked Wheel / Wg delete / Boost fooler
Tymar intake / Zoodad Mod / NChornet CCV mod
Hpx Crossover / Fuel CCK / ITP prepump tank mod
FPR Shim w/ underhood gauge
AIH Delete / Non Ebpv pedestal w/ valve delete
TW 6 position chip (will never own another canned toon)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

3.73's / 6 speed manual 4x4
Still messin with it
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Broncoguy is offline  
post #3 of 5 Old 12-01-2008, 05:16 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2008
Location: UP of Michigan
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
not sure on how old the plugs and relay are.....i know they are at least about 60k miles....prob more. So if i were to go to the parts store what should I ask for: glow plug control module??? thanx
pro11 is offline  
post #4 of 5 Old 12-01-2008, 06:07 PM
Emergency Services

 
Broncoguy's Avatar
 
Join Date: Jul 2008
Location: Benton City, WA
Posts: 338
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Glow Plugs

Yeah, just tell them glow plug controller and that should get them there. Probably be around a $150.00.

I would test the glow plugs first, just to be sure. Just pull the wires off the tips of the glow plugs and check with an ohm meter. Should be .5 - 1 ohm. If you don't have an ohm meter, take a test light and hook it to the positive side of your battery, touch the test light to the uncovered tip of the glow plug and if it lights up, it is most likely good.

Also check the ground wire on the glow plug controller, it should go to the valve cover. Be sure it is clean and connected properly.

Make sure to do all the tests on the glow plugs when they are cold (before startup)

Hope this helps

1999.5 F350
4" Straight Pipe / Gauges (Pyro, Boost)
Wicked Wheel / Wg delete / Boost fooler
Tymar intake / Zoodad Mod / NChornet CCV mod
Hpx Crossover / Fuel CCK / ITP prepump tank mod
FPR Shim w/ underhood gauge
AIH Delete / Non Ebpv pedestal w/ valve delete
TW 6 position chip (will never own another canned toon)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

3.73's / 6 speed manual 4x4
Still messin with it
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Broncoguy is offline  
post #5 of 5 Old 12-01-2008, 08:12 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2008
Location: UP of Michigan
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
cool...ya big help...thanx
pro11 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome