88 f250 electrical problems - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 10-30-2008, 04:00 PM Thread Starter
Powerstroke.org Rookie
Join Date: Oct 2008
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
88 f250 electrical problems

i got a 88 i just put a brand new alt. and batteries on and the batter light was on... did a voltage test it said 12.5 with fresh batteries... i tried a buddys alt. on my truck knowing his is good and still the same thing... input anyone?
stacked87f250 is offline  
Sponsored Links
post #2 of 2 Old 11-18-2008, 12:47 AM
Join Date: Nov 2008
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The batteries should be 12.6 full charge sitting with the truck off. The voltage should be at least 14 or so with the engine running. I say take a look at the connections first and foremost. Wire brush those suckers and make sure everything has a good connection.

If all is good, and the voltage comes above 12.6 when running, maybe it's the dummy light circuit at fault. ???
totalloser is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome