Is my turbo working? - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-20-2008, 07:39 AM
Member
 

Join Date: Jun 2008
Location: Anola, Manitoba
Posts: 40
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question Is my turbo working?

Recently purchase a 1993 F350 7.3L Diesel with Banks Sidewinder Turbo, 3" exhaust pipes with a Banks muffler.

It sounded sweet when I gave her or released fuel; had a nice whistling to it. But shortly after I got it, I opened the black aluminum box that sites on top of the intake manifold and discovered the air breather and it was about 80 to 90% plugged with crap; god know how it even ran. I cleaned it but now I can't hear any whistling so how do I know if the turbo is working? I miss the whistling sound. LOL

I forgot to mention that the Banks exhaust gauge shows the exhaust temp fluctuates between 500 to 600 and the manifold pressure gauge fluctuates between 1 & 2.

Last edited by Clydesdale; 10-20-2008 at 08:15 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-20-2008, 07:35 PM
Member
 

Join Date: Jun 2008
Location: Anola, Manitoba
Posts: 40
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Reply With Quote Quick reply to this message
  #3  
Old 10-25-2008, 10:04 PM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Ponchatoula, Louisiana
Posts: 986
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
That sound was most lickly the sound of the turbo sucking for air.
Reply With Quote Quick reply to this message
  #4  
Old 11-05-2008, 05:48 PM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,234
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
turbo wont just quit working , that model generally doesnt have much turbo noise , may want to get intake tube off turboi and make sure its spinning , thats about all you can do and make sure its gotta clean air filter
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:47 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors