Is my turbo working? - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 10-20-2008, 07:39 AM Thread Starter
Member
 
Clydesdale's Avatar
 
Join Date: Jun 2008
Location: Anola, Manitoba
Posts: 41
Thanks: 4
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Question Is my turbo working?

Recently purchase a 1993 F350 7.3L Diesel with Banks Sidewinder Turbo, 3" exhaust pipes with a Banks muffler.

It sounded sweet when I gave her or released fuel; had a nice whistling to it. But shortly after I got it, I opened the black aluminum box that sites on top of the intake manifold and discovered the air breather and it was about 80 to 90% plugged with crap; god know how it even ran. I cleaned it but now I can't hear any whistling so how do I know if the turbo is working? I miss the whistling sound. LOL

I forgot to mention that the Banks exhaust gauge shows the exhaust temp fluctuates between 500 to 600 and the manifold pressure gauge fluctuates between 1 & 2.

Clydesdale™
1993 F350 Crew cab Dually 4x4
7.3L Diesel with Banks Sidewinder Turbo
Auto tranny
============================
1986 F250 Ext. Cab Dually 4x4 Lariat
6.9L / 4 speed standard

Last edited by Clydesdale; 10-20-2008 at 08:15 AM.
Clydesdale is offline  
post #2 of 4 Old 10-20-2008, 07:35 PM Thread Starter
Member
 
Clydesdale's Avatar
 
Join Date: Jun 2008
Location: Anola, Manitoba
Posts: 41
Thanks: 4
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews

Clydesdale™
1993 F350 Crew cab Dually 4x4
7.3L Diesel with Banks Sidewinder Turbo
Auto tranny
============================
1986 F250 Ext. Cab Dually 4x4 Lariat
6.9L / 4 speed standard
Clydesdale is offline  
post #3 of 4 Old 10-25-2008, 10:04 PM
Compression Ignition Addict
 
highland512's Avatar
 
Join Date: Aug 2008
Location: Ponchatoula, Louisiana
Posts: 987
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
That sound was most lickly the sound of the turbo sucking for air.

-Matt
'04 350
ZF6
SCT 5015
highland512 is offline  
post #4 of 4 Old 11-05-2008, 05:48 PM
ADMIN AND TECH


 
SCUFFY828's Avatar
 
Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,316
Thanks: 0
Thanked 11 Times in 11 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
turbo wont just quit working , that model generally doesnt have much turbo noise , may want to get intake tube off turboi and make sure its spinning , thats about all you can do and make sure its gotta clean air filter

SCUFFY828@POWERSTROKE.ORG
ITS STOCK
SCUFFY828 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome