1994 IDI * ENGINE TEMP LIGHT ISSUES NEED HELP * - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-08-2013, 06:16 AM
Compression Ignition Addict
 

Join Date: Nov 2006
Posts: 194
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
1994 IDI * ENGINE TEMP LIGHT ISSUES NEED HELP *

Just bought a new toy to fix up and have a question I have never run into before. 1994 FORD F-350 CREW CAB DUALLY XLT with some sort of a hauler bed on it.
Truck has 89-k actual miles, 7.3 IDI turbo and runs and drives perfect. All the gauges work normal as they should but I have an engine temp light that comes on all the time. When the truck is cold the light is off but after it runs 2 or 3 mins. (well before is warms up) the light comes on....

I seen a few people has had this issue but no one tells how to fix it. Just tell that the sending unit may be bad....

Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-11-2013, 05:51 AM
Compression Ignition Addict
 

Join Date: Nov 2006
Posts: 194
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Problem fixed.... The secondary temp. sensor was bad.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:57 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors