7.3 idle problems - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 05-28-2008, 01:10 PM Thread Starter
Powerstroke.org Rookie
Join Date: May 2008
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
7.3 idle problems

hope you guys can help with this. got me a 93 with the 7.3 non turbo, yesterday it started idling high after driving it. this morning it started fine and idled fine, but after it warmed up it started idling at 1000 rpm. im fairly new to diesel engines. so be easy on me guys. but am competent enough to fix most things i encounter.

thanks in advance.
dumbhunter is offline  
Sponsored Links
post #2 of 2 Old 05-30-2008, 03:21 PM
Powerstroke.org Rookie
Join Date: Jan 2008
Location: Brenham,texas
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It sounds like to me the high idle sensor is bad.Its right beside the injector pump it pushes out on acclerator.My truck did this and I just unplugged the wire going to it and its been fine ever since.

96 Ford F350 westernhaulerflatbed 5''x36bullhaulers
Phillip A. is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome