low oil pressure? - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-18-2008, 10:41 PM
Powerstroke.org Rookie
 

Join Date: Apr 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
low oil pressure?

Hello all,
I recently purchased a 91 Ford 7.3 idi....I bought it for 1100.00 and it ran but stuttered...had a local diesel repair shop look it over....they rebuilt the injector pump (or said they did) and it ran fine for about a week .. I bought a Chiltons and went to work...found a loose connection on the sensor which mounts to the top of the fuel pump....Also found several shorted wires which were fixed. At the same time I replaced the fuel filter and changed the oil (synthetic). I decided to drive to Texas and back and it gave the same hard start problem. I made it back though and as soon as I pulled into my driveway it quit.

I found the fuel leak. The fuel pick up pump hose had about 10 leaks in it. I replaced it and also replaced the o-rings on the t's over the injector and the glow pugs. Started, ran and shifted alot better. However, I also noticed that during the two months I have driven the truck the oil pressure has fallen from half normal to before the N on normal. I checked the oil and it was black and thin (smelled like diesel). Figured this was due to the fuel problem. No coolent in oil or oil in coolant. No dripping oil or coolant leaks. Residual leaks where the oil cooler mounts to the block (towards front of truck), where tranny mounts and where the injectors meet the head (about 5 have residual leaks).

I am scared to drive it for fear of major break down. Does anyone have any idea on the low oil pressure indication?

additional things i noticed which may or may not be relevant are
1) felt a grinding from under the drivers floor area but the grinding has stopped recently.
2) before it quit the last time the oil pressure gauge lowered a hair and the engine temp gauge flunctuated back and forth from just before half and half (never did rise though).
3) I started the truck several times let it build compression, killed it and listened for a leak....I hear a very slow leak sounds like near the air breather hole (cant find it though) as far as I know it may be a bleed off valve...first diesel.

The "mechanic" told me that he found no blow by.....but this is the same guy who did not check the $2.00 fuel hose or replace the dryrotted fuel hose to at the fuel lines...or the o-rings for that matter. The truck starts first turn of the key and runs fine...but I am not chancing the low oil pressure indication.

Any help would be greatly appreciated. Thx.

Last edited by geauxtigers28; 04-18-2008 at 10:43 PM. Reason: grammer
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-13-2008, 02:37 PM
Member
 

Join Date: Sep 2007
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Same problem???

I have 1992 F250. In general seems to start OK and once started runs great (except I get bad mile per gallon (12 highway)), but I noticed that the oil pressure gauge is different every time. Some time it is near the "O" and some times the "R" in normal. If I change the oil it will be closer to the "M".
Thanks for the help
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:31 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors