93 7.3 idi hard start when warm - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-29-2013, 10:51 PM
Powerstroke.org Rookie
 

Join Date: May 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
93 7.3 idi hard start when warm

I have a 7.3 idi new batteries new injector pump and fuel filter also had it timed at a shop .she fires right up when cold and when warm you can start it right back up but if you let it sit for 10 min or so she will not start .you have to let it cool off and fires right back up I tried the room temp water trick and no go so im asking you guys for help or where to start ?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-03-2013, 08:43 PM
Powerstroke.org Rookie
 

Join Date: May 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
nobody has any ideas
Reply With Quote Quick reply to this message
  #3  
Old 07-09-2013, 07:47 AM
Powerstroke.org Rookie
 

Join Date: Dec 2012
Location: Markham
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just taking a guess. Maybe its a ground issue. Ground wire to starter? battery?
Reply With Quote Quick reply to this message
  #4  
Old 07-10-2013, 05:42 PM
Powerstroke.org Rookie
 

Join Date: May 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
just went through them all and cleaned them all list past week end no word on it working or not its the inlaws truck
Reply With Quote Quick reply to this message
  #5  
Old 07-15-2013, 03:36 AM
Powerstroke.org Rookie
 

Join Date: May 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
grounds all good I cleaned them all and still same problem im going to change starter someone told me the injector pump needs to spin at a certain rpm for the injector pump to open up or it will do this so im putting in a starter today if that doesn't work I have no clue where to start maybe the new injector pump is bad ?
Reply With Quote Quick reply to this message
  #6  
Old 08-18-2013, 08:35 PM
Powerstroke.org Rookie
 

Join Date: May 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
well it was the injector pump the new one was a bad one replace it and all is well
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:55 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors