1993 F250 IDI wont start - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-30-2013, 10:53 AM Thread Starter
Powerstroke.org Rookie
Join Date: May 2013
Location: East Aurora, NY
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exclamation 1993 F250 IDI wont start

Hey guys. Bought what ive wanted for a long time and its turned out to be, problematic to say the least. At first she needed a new radiator. replaced that. Then I cleaned both tanks and put them both back in and put fresh fuel in them. However, she wont start. I did all the lines and made sure they were getting fuel and they were. But even with a couple shots of ether nothing happens. It doesn't seem like the injectors are getting fuel which has me stumped. The (wait) light comes on and stays on for the correct time. But when the key is turned I hear two clicks then nothing, and it just cranks and cranks. So im lost, and I need some help. Thanks guys!

Brothernick is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome