I Need IDI Help!!! - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-18-2013, 07:19 PM Thread Starter
Powerstroke.org Rookie
Join Date: Mar 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Angry I Need IDI Help!!!

I have a 1991 Ford F-250, It Has a 7.3l Idi With the E40D. It has been acting real funny lately. It has been starting real hard in the morning and when it does a BIG cloud of white smoke pours out but then it stops any help? The main thing i am worried about is I replaced the lift pump, and filter about a month ago and has been running like a champ, But here the past couple of days i can be driving and it will just die! But i can throw it in neutral and it will start right up.????? i am lost! I am pretty sure i have a bad injector but would that cause that? or could it be the IP going out?
Hertman is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome