94 idi no start problem - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 02-28-2013, 08:46 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2013
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
94 idi no start problem

I have a 1994 7.3l idi, it has been sitting for a bit and will no start now. Wont even start with starting fluid, seems to crank over good. I would think it would still start with starting fluid even if the glow plugs werent working. I am starting to think maybe compression is the problem. If anyone has any thoughts that would be great thanks.
steven94idi is offline  
post #2 of 3 Old 03-02-2013, 07:40 AM
Powerstroke.org Rookie
 
Join Date: Mar 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'll tell you from my experience just start fluid won't start it. Try pulling the glow plugs , make sure the block heater has been pluged in. turn over engine several times, don't overheat starter. Watch for a little smoke coming out of glow plug holes (diesel fuel). They seem to depressurize the fuel system, when sitting for a while. Good time to check glow plugs with a ohm meter.replace glow plugs. Don't forget to use anti sieze on threads. 1/4"drive, 3/8 deep well socket, u-joint, & extensions required. Try starting. You might also push in on shrader valve(if you have one) with a small screw driver to check for a pressurized fuel system. Try starting. warning don't use to much starting fluid. Good luck. Joe
bigjoe is offline  
post #3 of 3 Old 03-02-2013, 07:47 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2013
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
thanks for the info, ya i am going to check compression today, got the kit from work and i got all new glow plugs, also got to fix my battery cables.
steven94idi is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome