'94 Tach Problems - Ford Powerstroke Diesel Forum

7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 12-25-2007, 05:27 PM Thread Starter
Compression Ignition Addict
 
powerstrokes only's Avatar
 
Join Date: Oct 2007
Location: Magdalena NM
Posts: 525
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
'94 Tach Problems

My '94 IDI Factory Turbo has an issue with the Tach at idle, or when I let off the accellerator when I am driving. It drops to zero until I touch the throttle, then it seems to operate accurately. I would'nt really worry but it has an E40D tranny and when it drops to zero the overdrive light blinks. It is directly linked to the tach, because it quits the instant I touch the throttle. I thought I had it fixed with a new speed sensor on the differintial,( it quit blinking for a couple of weeks) but it started again. Do I need to replace something on the tach? Whole tach system? Maybe clean it where it goes into the engine? If any body has any has any info. on tachs let me know. I am positive my blinking overdrive light is linked to the faulty tach, just have no idea how to deal with it. Thanks!

Fletcher
'90 F250 Supercab IDI 7.3
Banks Sidewinder Turbo
4'' straight pipe
116,000 miles

'94 F250 single cab IDI Factory Turbo 7.3
3'' banks down pipe
Banks pyrometer
3 1/2'' straight pipe
K&N Air filter
Hypermax air intake
Hydrogen Generator
Pump turned up
Timing advanced
315,000 miles!



'89 F250 4x4 supercab 7.3 IDI
4'' exhaust
pump turned way up!!!
297,000 miles
powerstrokes only is offline  
post #2 of 5 Old 12-25-2007, 05:31 PM
ADMIN AND TECH


 
SCUFFY828's Avatar
 
Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,314
Thanks: 0
Thanked 11 Times in 11 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
the tach is controled by the pcm, nowhere on the engine to clean a sensor, the tach itself is probably bad

SCUFFY828@POWERSTROKE.ORG
ITS STOCK
SCUFFY828 is offline  
post #3 of 5 Old 12-25-2007, 05:49 PM Thread Starter
Compression Ignition Addict
 
powerstrokes only's Avatar
 
Join Date: Oct 2007
Location: Magdalena NM
Posts: 525
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
This is an indirect injected engine, you can see where it screws into the engine by the oil fill on the front of the motor. I don't think I have a PCM with a mechanical injector pump, I know the tranny is computerized, would the tach be in connection with it? I know very little about a lot, I am really not a very good mechanic, usually just trial and error! Thanks for any help I get!

Fletcher
'90 F250 Supercab IDI 7.3
Banks Sidewinder Turbo
4'' straight pipe
116,000 miles

'94 F250 single cab IDI Factory Turbo 7.3
3'' banks down pipe
Banks pyrometer
3 1/2'' straight pipe
K&N Air filter
Hypermax air intake
Hydrogen Generator
Pump turned up
Timing advanced
315,000 miles!



'89 F250 4x4 supercab 7.3 IDI
4'' exhaust
pump turned way up!!!
297,000 miles
powerstrokes only is offline  
post #4 of 5 Old 12-25-2007, 06:18 PM
ADMIN AND TECH


 
SCUFFY828's Avatar
 
Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,314
Thanks: 0
Thanked 11 Times in 11 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
didnt realize it was idi, yes replace the tach sensor , i think its about 40 dollars , the tp sensor may also need to be replaced to fix trans problem, mounted on the side of the injection pump

SCUFFY828@POWERSTROKE.ORG
ITS STOCK
SCUFFY828 is offline  
post #5 of 5 Old 12-26-2007, 06:12 AM Thread Starter
Compression Ignition Addict
 
powerstrokes only's Avatar
 
Join Date: Oct 2007
Location: Magdalena NM
Posts: 525
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Thanks! I'll go look for one today.

Fletcher
'90 F250 Supercab IDI 7.3
Banks Sidewinder Turbo
4'' straight pipe
116,000 miles

'94 F250 single cab IDI Factory Turbo 7.3
3'' banks down pipe
Banks pyrometer
3 1/2'' straight pipe
K&N Air filter
Hypermax air intake
Hydrogen Generator
Pump turned up
Timing advanced
315,000 miles!



'89 F250 4x4 supercab 7.3 IDI
4'' exhaust
pump turned way up!!!
297,000 miles
powerstrokes only is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome