HELP charging system - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-20-2007, 06:32 PM Thread Starter
allergic to hot weather

 
95and05's Avatar
 
Join Date: Nov 2007
Location: Anchor Point, AK
Posts: 1,209
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to 95and05 Send a message via MSN to 95and05
HELP charging system

i am working on a borrowed truck (mine is a bare block now) and the charging system is not working. i am not very familliar with the older external regulator systems. all the wires to the regulator seem to be in tact--- i used an ohms meter to ck the wires i knew about but something aint right.
I- gets pwr with key on as it should
A- is constant hot as it should
S- has continuity to the s terminal on the alt but reads no voltage when running
F- has continuity to field terminal on alt but also reads no voltage when running

if i bypass the regulator and short field with pos i get about 6.5 varying volts at the S terminal. and it charges but not without the short.
3 new regulators have been tried also all same. WHAT SHOULD I BE LOOKING FOR???
THX in advance all.

Last edited by 95and05; 11-20-2007 at 06:34 PM. Reason: forgot some
95and05 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome