1988 7.3 hard starting - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 12-10-2012, 04:14 AM Thread Starter
Powerstroke.org Rookie
Join Date: Dec 2012
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
1988 7.3 hard starting

1988 F350 rollback 7.3. All trucks have personalities and cant figure mine out yet. Only owned for 3 days. It is suppose to have new glow plugs. I turn key and the word "engine" lights up and soon after I hear clicking. Is the clicking a sign to hit starter or time to wait? Both ways didn't work for me. It starts but will die and then the starting fluid has to come out to finally get it started. Do I need to gas her hard right when she goes? I've tried 15 sec and 30 sec after clicking starts same results. Whats the trick? Any help out there? My batteries are only 1-2 years old. I only get about 3 shots b4 they start giving up.
ollison is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome