Glow plug solenoid problem - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 10-31-2012, 06:10 PM Thread Starter Rookie
Join Date: Aug 2011
Location: Warsaw area
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Glow plug solenoid problem

A guy I work with just purchased a 93 F-350 that seems to have a GP solenoid problem. When he turns the key on the solenoid powers up the glow plugs but only for a split second. Then it shuts off. Yes, it's sending power to the all of the plugs and all of the plugs are good. It just doesn't glow the plugs for more than a 1/2 second before it kicks off. One other problem, which I think is relevent, the batteries will only crank the engine over for about 30 seconds before they go dead. NAPA tested them and said they are OK.
mrjimbov is offline  
Sponsored Links
post #2 of 2 Old 10-31-2012, 06:23 PM
Compression Ignition Addict
jesilvas's Avatar
Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,139
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 27 Times in 25 Posts
Feedback Score: 0 reviews
So, try a new relay.
Also, how did NAPA test them. Tied in parallel? Or load tested separately.

2000 F-350 Lariat Super Duty, Dually, CCLB, 7.3L
4R100, 2wd
330,000 + miles
jesilvas is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome