7.3 IDI , Air in fuel? Runs rough. - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-20-2012, 02:47 PM
Compression Ignition Addict
 

Join Date: Apr 2009
Posts: 196
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
7.3 IDI , Air in fuel? Runs rough.

My 1988 dump truck is a 7.3 banks turbo 5 speed. It starts up fine and idles smooth , and then it starts smoking a lot and running really rough with no power. It started this about a week ago. It was happening after about 20 minutes of driving, and of I would shut it off it would run smooth for 20 more minutes.now it's gotten to doing it after a few seconds every time. Im thinking it might be pulling air into the fuel system, I'm going to put a new filter on it and try to by pass my tank selector valve. Has anyone else experienced this problem,


Sent from my Autoguide iPhone app
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-29-2012, 08:03 PM
Compression Ignition Addict
 

Join Date: Jan 2009
Location: Almost to the Muck but not quite
Posts: 1,250
Thanks: 17
Thanked 48 Times in 47 Posts
Feedback Score: 0 reviews
ever figure it out?
Reply With Quote Quick reply to this message
  #3  
Old 09-07-2012, 01:21 PM
Compression Ignition Addict
 

Join Date: Apr 2009
Posts: 196
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I put a rebuild inj. Pump and its running great,


Sent from my Autoguide iPhone app
Reply With Quote Quick reply to this message
  #4  
Old 11-04-2012, 05:04 AM
Powerstroke.org Rookie
 

Join Date: Nov 2012
Location: Dallas, GA
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I just got mine back from being downed in the ship for two weeks. It was doing the same thing. Ended up just being the fuel shut off solenoid in the injector pump. $100 part. Then I was getting air in the fuel. So we bypassed the tank selector valve and ran new line from there back to the front tank after cleaning everything out to make sure there wasn't any trash. Truck runs like a champ now.


Sent from my iPhone using Autoguide.com Free App
Reply With Quote Quick reply to this message
  #5  
Old 11-09-2012, 02:53 PM
Compression Ignition Addict
 

Join Date: Apr 2009
Posts: 196
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
When I start it up it starts great, then after about 5-10 seconds it will try to stall, then i feather the throttle for 10 seconds and it's fine, it's pulling a little bit of air from somewhere.


Sent from my Autoguide iPhone app
Reply With Quote Quick reply to this message
  #6  
Old 11-09-2012, 03:34 PM
the baconator
 

Join Date: May 2009
Location: Easton MD 21601
Posts: 11,007
Thanks: 5
Thanked 35 Times in 35 Posts
Feedback Score: 1 reviews
when you figure it out let me know. we have a 6.9 that will fire, die and then run great after getting it to start the second time. have messed around with a bunch of things all from the filter back no fixes
Reply With Quote Quick reply to this message
  #7  
Old 11-11-2012, 04:12 PM
Compression Ignition Addict
 

Join Date: Apr 2009
Posts: 196
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Dodo you change the tank selector valve?


Sent from my Autoguide iPhone app
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:41 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors