I cant believe this - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 10-04-2007, 09:01 PM Thread Starter
Compression Ignition Addict
 
jwindbigler's Avatar
 
Join Date: Oct 2007
Location: Kalamazoo, MI
Posts: 522
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to jwindbigler
I cant believe this

So I just bought my first diesel pickup. An 89 F250. I bought it about two weeks ago. I had to replace the mechanical fuel pump, but other than that it was good to go. So I was driving on the I-8 today doing about 70MPH, and all of a sudden, the RPM start to climb, and I am loosing speed. So I push on the gas a little more. The RPM climb, but no power getting to the wheels. So I put in #2 gear. Same thing happens. Put it into first. Same response. Reverse. Same. Its like the damn thing was in neutral. Any ideas on what could have happened. We just filled the transmission with fluid a few days before (it was about 2 quarts low and it was shifting better). I thought that the torque converter may have gone out, but there was absolutely no sound when it went. Thanks guys.
jwindbigler is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 10-04-2007, 09:19 PM
Banned
 
Join Date: Apr 2007
Location: Ponca City, Okla
Posts: 1,089
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to Blue01F250 Send a message via Yahoo to Blue01F250
That definately sounds like the trans to me... but I'll bump this up for others to come alone
Blue01F250 is offline  
post #3 of 8 Old 10-05-2007, 12:40 PM Thread Starter
Compression Ignition Addict
 
jwindbigler's Avatar
 
Join Date: Oct 2007
Location: Kalamazoo, MI
Posts: 522
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to jwindbigler
So what could it be? A seal or maybe a vacuum line?
jwindbigler is offline  
post #4 of 8 Old 10-05-2007, 04:48 PM
Banned
 
Join Date: Apr 2007
Location: Ponca City, Okla
Posts: 1,089
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to Blue01F250 Send a message via Yahoo to Blue01F250
hrmm... -- see if you can post up a thread in the trans problems thread -- there was a member (ipz2222 I think) that is a trans guy -- he'll probably see it in there and be able to help you out -- I'm definately NOT very knowledgable on trans issues
Blue01F250 is offline  
post #5 of 8 Old 10-05-2007, 04:52 PM
BIG TRUCK, SMALL DRIVER
 
pipelayerjdh's Avatar
 
Join Date: Oct 2006
Location: Iva, SC
Posts: 5,877
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
What are the specs on your truck?

Derrick

My photobucket




'97 F-350 "FORDOR" 4X4 (Dually Conversion, Shackle Reversal, Technicooler , Auto Meter Gauges, 4" DIY Dual Exhaust w/ '08 tips, 4" DIY intake w/ AEM filter, Wicked Wheel 2, 360 thrust bearing, Homemade E-fuel conversion, Wildman Chip, 160cc DIY injectors , DIY IDM mod) 230K and counting...
pipelayerjdh is offline  
post #6 of 8 Old 10-06-2007, 05:33 PM Thread Starter
Compression Ignition Addict
 
jwindbigler's Avatar
 
Join Date: Oct 2007
Location: Kalamazoo, MI
Posts: 522
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to jwindbigler
Dude I have no idea. Its completely stock with the 446 and a 3 spd auto. Other than that I really have no idea.
jwindbigler is offline  
post #7 of 8 Old 10-06-2007, 06:37 PM
Compression Ignition Addict
 
Join Date: Jul 2007
Posts: 5,612
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 5
Thanked 13 Times in 13 Posts
Feedback Score: 0 reviews
torque converter sounds like......my 93 f250 did the same thing..... 1500 at ford....12 years ago

Quote:
Originally Posted by Ianstew
There is a difference in a government acting responsibly within their powers, and a government that just decides what their powers are and what responsibility means based on political whimsy.
ianstew is offline  
post #8 of 8 Old 10-07-2007, 05:54 PM Thread Starter
Compression Ignition Addict
 
jwindbigler's Avatar
 
Join Date: Oct 2007
Location: Kalamazoo, MI
Posts: 522
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to jwindbigler
Quote:
Originally Posted by ianstew View Post
torque converter sounds like......my 93 f250 did the same thing..... 1500 at ford....12 years ago
We checked the torque converter. Its not it. Its definately putting pressure to the transmission and its not turning the driveshaft. Anyone know what transmissions will bolt up to this. Manual or Automatic? I am very new to ford and the diesel, so I really dont know anything about them. Here is an example of what I am looking for...the T56 is a manual transmission that came on the Vipers, 97-current vettes, 03-04 Cobra, 93-current Trans Am/Camaro/GTO...ect. Something like that but with ford products. Thanks.
jwindbigler is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome