94 Factory Turbo IDI making Trans noise or Something else? - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-05-2012, 05:39 PM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
94 Factory Turbo IDI making Trans noise or Something else?

So I just had received my Grandfathers 94 IDI 7.3 Factory Turbo F350 with an Automatic Trans. Ive owned 2 97 Powerstrokes previously but am new to the IDI Turbo. The truck is all original and was kept up with maintenance wise. The trans doesnt have more then 30k on a beefy rebuild and the truck has 185k. It shifts nice and firm and seems to hold the gears as it should. The noise is like a metal on metal grind with a howl sometimes as well.. It almost sounds like its coming from under the dash or under the floorboard. The noise also isnt a consistent sound it is very erratic. It seems to happen around 2000rpm and will clear up around 2800rpms and also when I let off the throttle it goes away.On the freeway is where it is most noticeable but when I drive it on the city it doesnt happen every time i go through the gears. In park when I rev it it sounds great with no noises....... Any suggestions would be awesome! I need to get it running good so I am not scared to drive it!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-29-2012, 07:56 PM
Compression Ignition Addict
 

Join Date: Jan 2009
Location: Almost to the Muck but not quite
Posts: 888
Thanks: 5
Thanked 25 Times in 25 Posts
Feedback Score: 0 reviews
I realize this post is a bit old but it kinda sounds like you have a cracked flywheel. IDI's are notorious for it I have a 94 IDI factory turbo as well, and i love it. Has 435k miles on it! My trans went out a while back and i put a new one in it. I didnt even notice the cracks until a friend of mine showed me i had to look very close. Hope this helps and GL
Reply With Quote Quick reply to this message
  #3  
Old 08-01-2012, 11:33 AM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sorry but I forgot to add that the problem ended up being a Clamp on the downpipe hitting the firewall....WOW, talk about lucking out right.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:35 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors