what did you do to your idi today ? - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-25-2012, 04:36 AM
Powerstroke.org Rookie
 

Join Date: Apr 2012
Location: centreville, MI
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
what did you do to your idi today ?

ok so most forums have one of these threads, i found one in the 99 up 7.3 section but couldn't find one for the idi's weather it be the 6.9 or the 7.3 so here it is .
I'll start out


Bougt it sunday the 24 th, monday i replaced the left and rite side headlight assemblys (one was melted and one was nasty foggy) with fairly nice junk yard finds and fixed the shotty battery cable replacement the p.o. did, today i hacked the rotted exhaust off under the cab where it was solid and started plumbing in my stack!




Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-25-2012, 04:25 PM
Powerstroke.org Rookie
 

Join Date: Apr 2012
Location: centreville, MI
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Finished my stack today and torched those ugly twisted/bent up plow brackets off






Last edited by 94f250idi; 04-25-2012 at 05:51 PM.
Reply With Quote Quick reply to this message
  #3  
Old 04-25-2012, 05:32 PM
Member
 

Join Date: May 2010
Posts: 69
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
nice looking fine. wish mine sat up that high in the front.. keep us updated on mods.
Reply With Quote Quick reply to this message
  #4  
Old 04-25-2012, 05:47 PM
Powerstroke.org Rookie
 

Join Date: Apr 2012
Location: centreville, MI
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks, its got helper springs from having a snow plow but eats tires because of them, Going to do a SAS when i find an axle

Last edited by 94f250idi; 04-25-2012 at 05:59 PM.
Reply With Quote Quick reply to this message
  #5  
Old 05-08-2012, 04:01 PM
Powerstroke.org Rookie
 

Join Date: Apr 2012
Location: centreville, MI
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
last tuesday i pulled the trans pan off and put in a new filter and gasket and drilled a hole and installed a drain plug then i welded in a 1/8 npt bung for a temp sensor, wednesday i installed a prosport pyro and a b&m trans temp gauge then today i installed a new tps and a serpentine belt
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:38 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors