New and need help - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 01-21-2012, 03:28 AM Thread Starter
Powerstroke.org Rookie
 
Tankgod's Avatar
 
Join Date: Jan 2012
Location: Stevensville, MT
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
New and need help

Hey all, Im new in here and trying to figure out what is going on with a 92 f-350 I just got. I just replaced the injectors and lines and adjusted the idle back to around 500-600 (which is where I was told it was supposed to be) but I cant seem to figure out why its still smoking while not loaded and going down the road. its a 7.3, 5 speed cc. anybody that can help would be awesome..
Tankgod is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 01-22-2012, 06:28 PM
Member
 
Join Date: Mar 2011
Location: Fowlerville, MI
Posts: 61
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
welcome to the forum.

what color smoke is the truck putting out?
'94IDITurbo7.3L is offline  
post #3 of 4 Old 01-22-2012, 10:09 PM Thread Starter
Powerstroke.org Rookie
 
Tankgod's Avatar
 
Join Date: Jan 2012
Location: Stevensville, MT
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks, Its grey when going down the road even empty, but when its just sitting it acts pretty normal. Very little smoke on start up and black at around 3K. Also at an idle it smells like body odor or something bad like that..lol
Tankgod is offline  
post #4 of 4 Old 01-30-2012, 10:50 PM
Compression Ignition Addict
 
tjmp111's Avatar
 
Join Date: Aug 2007
Location: Ellensburg WA
Posts: 162
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sounds like timing.

tjmp111 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome