leak either at an injector line or the pump.. - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-19-2011, 04:17 PM
Powerstroke.org Rookie
 

Join Date: Nov 2011
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
leak either at an injector line or the pump..

sometime today (not really sure when) my truck started falling flat on its face and running like junk. i didn't think anything of it till about a hour ago and found out that i and a decent puddle on the top of my motor. i'm thinking its one of my injector lines more then anything but i'm not going to throw anything aside until i look at it tomorrow. so my main question is where would a good place to get injector lines and would it be a good i idea to get a step up injectors? is there any like recalls or common problems with the injection pumps with blowing seal or anything like that? i'm fairly new to to idi's and the problems and what not so looking for some hints or suggestions on what to do. thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-19-2011, 06:52 PM
Member
 

Join Date: Sep 2010
Location: Gillham, Ar.
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
probably just a $35 o-ring and hose kit is all it needs. a simple job. just done it the other day
Reply With Quote Quick reply to this message
  #3  
Old 11-20-2011, 10:40 PM
Powerstroke.org Rookie
 

Join Date: Nov 2011
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
no it turned out the #2 injector line was broken at the pump fitting ill post a pic of it tomorrow when i get the chance. i think what happened was the drive side lines didnt have the bracers or whatever there called to hold the lines from vibrating to much and it broke the line right behind the flare on the pump side of the line.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:57 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors