HELP!! 7.3 IDI REVS, POPS, AND MISSES - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-16-2011, 02:45 PM
Powerstroke.org Rookie
 

Join Date: Apr 2009
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
HELP!! 7.3 IDI REVS, POPS, AND MISSES

93 factory turbo. 180k miles. truck ran fine the night before....next it started this right upon start up. they are new injectors..is it possible they were bad?

bad injectors? 7.3 idi turbo - YouTube
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-16-2011, 02:47 PM
Powerstroke.org Rookie
 

Join Date: Apr 2009
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i cracked all the injector lines and they are all getting fuel...it is a newer injection pump as welll...im stumped. the truck has NO blow by. and barely smoke...when it pops/misses a light puff of black smoke will come out
Reply With Quote Quick reply to this message
  #3  
Old 10-16-2011, 02:50 PM
Powerstroke.org Rookie
 

Join Date: Apr 2009
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
the injectors are 3-4 months old and have been fine the whole time
Reply With Quote Quick reply to this message
  #4  
Old 10-16-2011, 03:02 PM
The Tamed Racing Driver
 

Join Date: Oct 2009
Location: Home-Taneytown, Maryland; School- Lima, Ohio
Posts: 3,229
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
You might have one dribbling. Take them out and have them pop tested.
Reply With Quote Quick reply to this message
  #5  
Old 10-16-2011, 03:05 PM
Powerstroke.org Rookie
 

Join Date: Apr 2009
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
hopefully it is just an injector issue. is that what it sounds like to you?
Reply With Quote Quick reply to this message
  #6  
Old 10-16-2011, 03:08 PM
The Tamed Racing Driver
 

Join Date: Oct 2009
Location: Home-Taneytown, Maryland; School- Lima, Ohio
Posts: 3,229
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Where did you get them from. I could see a dribbling injector making that noise.
Reply With Quote Quick reply to this message
  #7  
Old 10-19-2011, 11:38 AM
Powerstroke.org Rookie
 

Join Date: Apr 2009
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
injectors tested out good
im lost.....could the IP be bad causing this?
Reply With Quote Quick reply to this message
  #8  
Old 10-20-2011, 04:09 PM
Powerstroke.org Rookie
 

Join Date: Apr 2009
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
took the IP in for testing today. they took the cover off and found metal shaving. they said a retainer ring had came apart. pump is getting rebuilt tomorrow. all should be good!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:44 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors