New 7.3 owner-need input on starting - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-12-2011, 04:05 AM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Location: Knoxville, TN
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
New 7.3 owner-need input on starting

Hello to all! New to this forum and new owner of a beauty of a ride. Last week, I purchased a 1990 Ford F250 extended cab, 2-wheel drive with a 7.3 IDI. This truck is a monster and in excellent shape and only has 150,000 miles on it. I hadn't started it since I bought it last Friday, but when I went to crank it last night, it had trouble firing. When I turned the key and waited for the light to go out, I noticed a loud clicking. It turned over several times, before finally starting after the fourth attempt. I drove it around the neighborhood and after that, it started several times with no problems. This morning, I went to crank it again. This time, I got the same clicking noise, but it started on the first try but idled kinda sluggish for a little while before settling into a smooth idle. I'm thinking this might be the glow plug relay switch or perhaps the glow plugs themselves. The clicking noise made me think it might be the relay switch. Does this sound familiar to anyone? Thanks, in advance, for the advice!

Last edited by Old Skool; 08-12-2011 at 04:13 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-12-2011, 07:34 AM
Member
 

Join Date: Mar 2011
Location: Fowlerville, MI
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Welcome to the forum.

You are correct. that clicking you hear after the WTS light goes out is the glow plug relay turning on and off. That is normal. How long does the WTS light stay on for? it should normaly be right around 10 sec but no more than 15 sec iirc. if the light is only on for a few seconds on cold start-up then you have at least one glow plug bad. to test the plugs get a 12v test light. connect the test light lead to the positive post on one of the batteries. pull the connectors off the glow plugs. touch the test light to the top of the glow plug. if the light comes on then the plug is good. if the light does not come on then the plug is no good. If new plugs are needed only get Motorcraft/Beru ZD9 iirc.

When you said the idle was kind of sluggish i would mabey suspect an injector does not have that long to live. Does the engine still have the original injection pump and injectors in it. if so it would be time to replace both. they have a good service life of about 100,000 miles. after that their performance starts to go away. along with MPG.
Reply With Quote Quick reply to this message
  #3  
Old 08-12-2011, 08:50 AM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Location: Knoxville, TN
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I really didn't pay that much attention to how long the light stayed on for, but will pay attention to it over the weekend and report on how it did. This website is awesome for troubleshooting and overall good info. Thanks for your input! Also, will the engine continue to run with a bad injector or simply shutdown altogether? Not sure if its the original injectors or not.

Last edited by Old Skool; 08-12-2011 at 08:53 AM.
Reply With Quote Quick reply to this message
  #4  
Old 08-12-2011, 11:30 AM
Member
 

Join Date: Mar 2011
Location: Fowlerville, MI
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Old Skool View Post
Also, will the engine continue to run with a bad injector or simply shutdown altogether? Not sure if its the original injectors or not.
The engine will continue to run even with one bad injector. the quality of its running, mpg, & performance will not be so great. if you have to move the truck or HAVE to drive it to work or what not then OK but should really get all 8 pop tested and changed out if needed. if they are originals then don't worry about pop testing them and just get new ones. If they are original injectors then they will have greay paint on them like the valve covers do, unless the valve covers have been painted by somebody. one the hex-head on the injectors were you would put a wrench on to take them out there will be a stamped letter on there. iirc your year engine will have "E" code injectors. When you buy new ones get the "BB" code injectors. if at all possible try to get new injectors not remans. i am not sure of the differences between the two injectors but it has been reported time and time again that when guys go to "BB" codes it is like adding two more cylinders to the engine. they actually report increase mpg and performce. when my injectors died my truck was hard to start and it smokes a lot of white smoke on acceleration. got them pop tested and 4 of them were bad. the other 4 were on the lower end of spec for pop pressure. got new ones and made a big difference. them my IP started to leak. got a new IP and that made a big difference.

Last edited by '94IDITurbo7.3L; 08-12-2011 at 11:34 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:00 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors