i got nothing ???? - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-08-2011, 08:22 PM Thread Starter
Powerstroke.org Rookie
Join Date: May 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i got nothing ????

k here is what happened.... going down the highway i siezed my alternator which in turn DESTROYED my belt the belt wrecked both idler pulleys, transmission cooler lines and got wrapped around everything and made a big mess so anywyas go and get all my new parts put everything back toghether go to start the truck and i got nothing..... u could hear the glow plugs cycle threw and then nothing i mean no turn over ...acting as if dead batteries so we tow the truck home.... put the charger on both batteries all night and still nothing but now sometimes glow plugs go on and sometimes not ??? now i have replaced the solenoid for started or whatever it is mounted on the side of passenger side fender ... still nothing so then i took the starter out had it tested works fine ok..... as i was putting it back we turnd the crank over by hand to make sure it wasnt siezed and it turned over fine put everything back together and if fired up yay.... but blew another belt 6miles later got a new one under warrenty and blew it 6 mile later looked and finally figured i had a pulley not quite right so fix that got everything back together and its fires right up yay .... go in the house for a few hours comeback out to start again and i got NOTHING ?????? any help is greatly appreciated thanks

ps. i have tested all my wires with for currrents and ohms and all that... i just watched not sure exactly but everything seems intact and with lots of current
2tone is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome