new ip - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-29-2011, 02:43 PM
Compression Ignition Addict
 

Join Date: Mar 2009
Location: Magna
Posts: 151
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
new ip

hey everyone. i just put on a new injector pump. well after i did i tried to to start the beast up and all it does is crank. shot some either into it ( i know that's a no no) but when i did it started for a brief sec and then died. can anyone help?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-29-2011, 10:43 PM
Banned
 

Join Date: Oct 2009
Location: Riverside/Norco, Ca
Posts: 3,771
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
is it installed correctly? the the gears lined up?
Reply With Quote Quick reply to this message
  #3  
Old 05-05-2011, 07:35 AM
Compression Ignition Addict
 

Join Date: Mar 2009
Location: Magna
Posts: 151
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yes i triple checked everything. i guess it needs to be primed. i have cranked it so many times and ran the battery down to nothing twice now and it still doesnt want to start and run. i am starting to get pissed off.
Reply With Quote Quick reply to this message
  #4  
Old 06-15-2011, 07:04 AM
Member
 

Join Date: Mar 2011
Location: Fowlerville, MI
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
need to get all of the air out of the system.
On second thought, if you have run down the batteries a couple of times the air should have been forced out of the system by now. Do you have the wires on the IP in the correct spots?
Would not recomend running down the batteries b/c that is hard on starters.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:40 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors