starting issue - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-25-2011, 06:43 PM
Powerstroke.org Rookie
 

Join Date: Apr 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
starting issue

just replaced the glow plug relay one of the batteries was the wrong one replaced that has failry new glow plugs fuel filter new injector pump and this thing wont start when the engine is cold it can be 85 outside the thing wont start only way i can get it to start is with starting fluid whcih i know is bad for it but i have no choice it is my daily driver any help would be great thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-23-2011, 09:40 AM
Member
 

Join Date: Apr 2007
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I am Battling the same problem with one of my trucks on my fleet. My mechanic and i have replaced relays, glow plugs, and the list goes on but my shop mechanic is quite knowledgeable and really understands electrical systems. So after all of the bad electrical parts have been replaced it starts after quite a bit of cranking. Now we are looking into the fuel shut-off solenoid. He thinks that the fuel might be draining back to the tank and taking a long time to fill back up. Oh and it has been our experience that when one battery goes bad that you should replace both. The reason being after a little bit the older of the two will drain the newer one.

Last edited by blksmk; 05-23-2011 at 09:44 AM.
Reply With Quote Quick reply to this message
  #3  
Old 05-24-2011, 12:24 AM
Powerstroke.org Rookie
 

Join Date: Oct 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I agree with blksmk I ran into the battery issue as well!!!!!!!! Be careful cranking on that starter to long I just had to replace mine along with the glow plug relay glow plugs and alternator!!!! Excessive cranking can hurt a lot of things!!!!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:32 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors