new to me 93 idi turbo - Ford Powerstroke Diesel Forum

7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 03-23-2011, 12:22 AM Thread Starter
Compression Ignition Addict
 
champaignPS's Avatar
 
Join Date: Mar 2009
Location: Magna
Posts: 151
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
new to me 93 idi turbo

hey everyone, so i am new to the idi system. so i bought this truck last friday, it had a oil leak coming from under the turbo into the pedistol. put a new o ring in it and now its leaking from the bottom of the pedistol. i have heard and read of people getting a pcv rubber boot and that fixes it. and i noticed while i had the turbo off the exhaust flange gasket (metal) was worn out and barely together. does anyone know of a fix for that as well? i went to the dealership and they dont have anything what so ever. i need to get this truck up and running and cant do it with the oil leaks and i would hate to put it back on the road knowing that the exhaust leaks. anyone know of a cheap easy solution???

1996 F-250PSD, Straight pipe 4" exhaust, 5speed manual tranny. more to come eventually
champaignPS is offline  
post #2 of 7 Old 03-23-2011, 07:27 AM
Powerstroke.org Rookie
 
bendoverand97007's Avatar
 
Join Date: Oct 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
yes the rubber boot does work had a buddy do it where her got it or what it was i am not sure!!!! For the exhaust figure what kind of kit that it is and u should be able to order one through the company that made the kit!!! It is an aftermarket kit being that it is a 93 and they were not a turbo truck!!!
bendoverand97007 is offline  
post #3 of 7 Old 03-23-2011, 11:33 AM Thread Starter
Compression Ignition Addict
 
champaignPS's Avatar
 
Join Date: Mar 2009
Location: Magna
Posts: 151
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
well thank you for the info. i will try to get this oil leak to stop with one of those. and IT IS a stock turbo. its actually a late model 93.

1996 F-250PSD, Straight pipe 4" exhaust, 5speed manual tranny. more to come eventually
champaignPS is offline  
post #4 of 7 Old 03-24-2011, 11:45 AM
Compression Ignition Addict
 
FordGuy100's Avatar
 
Join Date: Jun 2008
Location: Silverton, OR
Posts: 2,492
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Its a T3 exhaust housing, any metal gasket should fit it. Getting that turbo off the pedistal is a pain huh?

-Justin-
1985 Ford F-250 with a 6.9 IDI/T-19 4speed 4x4
Paint, Eagle Alloys, Kelly Safari TSR's, ATS turbo, gauges

2004 Jetta TDI 5 speed
2004 2wd Excursion Limited 6.0. Testing how loyal I am to Ford
1997 Passat B4V TDI. 1 of 80 imported in 97. 50 MPG and a factory 25 gallon fuel tank!
FordGuy100 is offline  
post #5 of 7 Old 03-25-2011, 10:11 PM Thread Starter
Compression Ignition Addict
 
champaignPS's Avatar
 
Join Date: Mar 2009
Location: Magna
Posts: 151
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
so i have taken off the turbo and put it all back together. now its blowing white smoke out the exhaust. i cant figure out whats going on. the guy i bought it from said he changed the head gaskets.

1996 F-250PSD, Straight pipe 4" exhaust, 5speed manual tranny. more to come eventually
champaignPS is offline  
post #6 of 7 Old 03-26-2011, 08:56 PM
Compression Ignition Addict
 
powerstrokes only's Avatar
 
Join Date: Oct 2007
Location: Magdalena NM
Posts: 525
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by bendoverand97007 View Post
yes the rubber boot does work had a buddy do it where her got it or what it was i am not sure!!!! For the exhaust figure what kind of kit that it is and u should be able to order one through the company that made the kit!!! It is an aftermarket kit being that it is a 93 and they were not a turbo truck!!!
They did offer a Factory Turbo in '93 and a non. My buddy had one we drove 500,000 plus miles.

Fletcher
'90 F250 Supercab IDI 7.3
Banks Sidewinder Turbo
4'' straight pipe
116,000 miles

'94 F250 single cab IDI Factory Turbo 7.3
3'' banks down pipe
Banks pyrometer
3 1/2'' straight pipe
K&N Air filter
Hypermax air intake
Hydrogen Generator
Pump turned up
Timing advanced
315,000 miles!



'89 F250 4x4 supercab 7.3 IDI
4'' exhaust
pump turned way up!!!
297,000 miles
powerstrokes only is offline  
post #7 of 7 Old 03-26-2011, 09:52 PM
Compression Ignition Addict
 
Join Date: Jul 2007
Posts: 5,626
Thanks: 5
Thanked 13 Times in 13 Posts
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Feedback Score: 0 reviews
i miss my IDI.

Quote:
Originally Posted by Ianstew
There is a difference in a government acting responsibly within their powers, and a government that just decides what their powers are and what responsibility means based on political whimsy.
ianstew is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome