1993 ford f350 7.3 IDI glow plug relay issues - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-19-2010, 05:27 PM
Powerstroke.org Rookie
 

Join Date: Oct 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
1993 ford f350 7.3 IDI glow plug relay issues

Hello i went to clean the contacts on my old glow plug relay and nut on power wire broke so i had to buy new glow plug relay,now after installing the new relay all it does is click on and off for about 40 seconds and thats it wont start old one came on for a couple seconds and shut off as is should the new one just clicks on and off as i stated wires are on correctly,any advise would be greatly appreciated,I removed new relay a dozen times and reinstalled it still doing same thing,has anyone else had this issue after installing new gpr?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-19-2010, 05:34 PM
Shaking the Bush Boss
 

Join Date: Feb 2007
Location: Salisbury, NC
Posts: 9,740
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bump up for ya
Reply With Quote Quick reply to this message
  #3  
Old 12-20-2010, 04:14 AM
Powerstroke.org Rookie
 

Join Date: Feb 2010
Location: Grass Lake, MI
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
When you first turn the key on, the relay should stay on for I think between 30~60 seconds, there are other posts to this effect, and then cycle on and off which is the clicking you are hearing. If it starts cycling right away, you either have bad glow plugs or something else in the wiring to the plugs.
Reply With Quote Quick reply to this message
  #4  
Old 12-20-2010, 03:08 PM
Powerstroke.org Rookie
 

Join Date: Oct 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
GPR ISSUE

i went to clean the contacts on my OLD glow plug relay and nut on power wire broke so i had to buy NEW glow plug relay,now after installing the NEW relay all it does is click on and off for about 40 seconds and thats it wont start old one came on for a couple seconds and shut off as is should the new one just clicks on and off as i stated wires are on correctly,any advise would be greatly appreciated,I removed new relay a dozen times and reinstalled it still doing same thing,has anyone else had this issue after installing new gpr? All glow plugs are new,
Reply With Quote Quick reply to this message
  #5  
Old 12-25-2010, 09:44 AM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: Magdalena NM
Posts: 525
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My '94 did the same thing with a new relay the other day, went on oilburners.com and found a way to bypass the relay with a momentary switch. It was super easy and I have never had an IDI start like this one does now, I will always do this bypass on all my IDI's from now on!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:05 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors